geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel S. Haischt" ...@stefan.haischt.name>
Subject Re: [Fwd: Re: [ISSUE] Eclipse Tools / Geronimo Plugin]
Date Fri, 30 Dec 2005 13:59:57 GMT
Yes, I can open a Jira ticket.

Sachin Patel schrieb:
> Would you mind opening a jira?  I'm about to head out of town, so  i'll
> take a look when I get back.  FYI This actual feature/plugin is  not a
> requirement for the server adapter to run.  The plugin when  built wraps
> a Geronimo server image inside the plugin and then that  feature (thus
> the server) can be installed from eclipse without a  user having to get
> the distribution from the web site.
> 
> The actual implementation of this support is incorrect, as the zip 
> should not have to be wrapped inside the plugin.  I'm working with  the
> WTP folks to get a correct implementation put into WTP 1.1.  So  this
> plugin may go away.
> 
> - sachin
> 
> 
> 
> On Dec 30, 2005, at 8:42 AM, Daniel S. Haischt wrote:
> 
>> Hello,
>>
>> Sachin thanx for fixing the MANIFEST issue. Tho - the issue with  the ...
>>
>>  -> org.apache.geronimo.j2ee.server.v1
>>
>> ... plugin still remains. This is the exact message I am getting  inside
>> Eclipse:
>>
>> --------8<---------8<------------8<----------8<-------
>> Plug-in "org.apache.geronimo.j2ee.server.v1" version
>> "0.5.0" referenced by this feature is missing.
>> -------->8--------->8------------>8---------->8-------
>>
>> If looking at the generated zip in ...assembly/target/distributions,
>> one would realize that there's neither a ...j2ee.server.v1 directory
>> nor an equivalent jar file in it.
>>
>> BTW, I did a fresh SVN checkout ...
>>
>> Two remaining issues:
>>
>>  * I did use the command ...
>>    -> maven -Declipse.home=/opt/eclipse-3.1.1 \
>>    -> -Dgeronimo.version=1.0-SNAPSHOT
>>
>>    but maven did search for openejb-pkgen-build-2.0.jar instead
>>    of openejb-pkgen-build-2.0-SNAPSHOT.jar. Thus I had to create
>>    some symlinks to quickly fix the issue.
>>
>>  * After having recompiled the Geronimo plugin for Eclipse I did
>>    extract the resulting zip into my Eclipse 3.1.1 directory tree.
>>    Inside Eclipse I had to realize, that the two Geronimo features
>>    within my configuration, were de-activated. Tho - I was only
>>    able to activate the geronimo feature but not the  installableruntime
>>    feature because of the missing j2ee plugin.
>>
>> My Configuration:
>>
>> --------8<---------8<------------8<----------8<-------
>> Eclipse 3.1.1 (Build: M20050929-0840)
>> Eclipse command: eclipse -clean -vmargs -Xms64m -Xmx512m
>> Java SE Version: 1.5.0_06
>> -------->8--------->8------------>8---------->8-------
>>
>> -------- Original-Nachricht --------
>> Return-Path: <dspam@imap.abyssworld.de>
>> Received: from murder ([unix socket])     by imap.abyssworld.de (Cyrus
>> v2.2.12) with LMTPA;     Fri, 30 Dec 2005 04:45:57 +0100
>> X-Sieve: CMU Sieve 2.2
>> Received: from smtp.abyssworld.de (smtp.abyssworld.de 
>> [192.168.1.6])    by
>> smtp.abyssworld.de (Postfix) with ESMTP id 119C51B8DC    for
>> <me@stefan.haischt.name>; Fri, 30 Dec 2005 04:45:55 +0100 (CET)
>> Received-SPF: neutral (smtp.abyssworld.de: 68.142.206.240 is neither
>> permitted nor denied by domain of gmail.com) client-ip=68.142.206.240;
>> envelope-from=sppatel2@gmail.com;  helo=smtp107.plus.mail.mud.yahoo.com;
>> Received: from smtp107.plus.mail.mud.yahoo.com
>> (smtp107.plus.mail.mud.yahoo.com [68.142.206.240])    by 
>> smtp.abyssworld.de
>> (Postfix) with SMTP id EB0E01B8C2    for <me@stefan.haischt.name>; 
>> Fri, 30
>> Dec 2005 04:45:51 +0100 (CET)
>> Received: (qmail 12667 invoked from network); 30 Dec 2005 03:45:50  -0000
>> Received: from unknown (HELO ?192.168.1.4?) (spalias78@71.65.234.198
>> with plain)  by smtp107.plus.mail.mud.yahoo.com with SMTP; 30 Dec 2005
>> 03:45:50 -0000
>> Mime-Version: 1.0 (Apple Message framework v746.2)
>> In-Reply-To: <43B46C60.5090004@daniel.stefan.haischt.name>
>> References: <43B46C60.5090004@daniel.stefan.haischt.name>
>> Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
>> Message-Id: <4621C850-7D61-4101-B133-E62A5D4EC670@gmail.com>
>> Content-Transfer-Encoding: 7bit
>> From: Sachin Patel <sppatel2@gmail.com>
>> Subject: Re: [ISSUE] Eclipse Tools / Geronimo Plugin
>> Date: Thu, 29 Dec 2005 22:45:50 -0500
>> To: me@stefan.haischt.name
>> X-Mailer: Apple Mail (2.746.2)
>> X-Virus-Scanned: ClamAV using ClamSMTP 1.4.1
>> X-DSPAM-Result: Innocent
>> X-DSPAM-Processed: Fri Dec 30 04:45:57 2005
>> X-DSPAM-Confidence: 0.8418
>> X-DSPAM-Probability: 0.0000
>> X-DSPAM-Signature: 43b4ad75730831610688996
>> X-DSPAM-Factors: 27,    running+is, 0.00010,    the+adapter, 0.00010,
>> few+issues, 0.00010,    the+WTP, 0.00010,    for+catching, 0.00010,
>> Subject*Geronimo, 0.00020,    From*Sachin+Patel, 0.00020,    article+for,
>> 0.00020,    WTP+plugin, 0.00020,    From*Sachin, 0.00020,    MF+contains,
>> 0.00020,    plugin, 0.00136,    plugin, 0.00136,    Subject*Plugin,
>> 0.00147,
>> INF, 0.00175,    INF, 0.00175,    plugins, 0.00219,
>> Content-Type*ASCII+delsp, 0.00270,    wrote+Hello, 0.00310,   
>> the+plugins,
>> 0.00418,    Content-Type*delsp+yes, 0.00459,    Content-Type*yes,
>> 0.00459,
>> Content-Type*delsp, 0.00459,    Geronimo, 0.00481,    Received-SPF*yahoo,
>> 0.99449,    directory+In, 0.00600,    plugin+but, 0.00600
>>
>> Hi, Thanks for catching the Manifest version mismatches, I've fixed
>> these.
>>
>> As for the installableruntime.feature, the j2ee.server plugin is
>> located inside the plugins directory.
>>
>> In the future, please send notes to the dev list, this way others can
>> see the same questions responses as well.
>>
>> Thanks.
>>
>> - sachin
>>
>>
>>
>> On Dec 29, 2005, at 6:08 PM, Daniel S. Haischt wrote:
>>
>>> Hello,
>>>
>>> I am trying to compile the Geronimo WTP plugin for Eclipse from
>>> source (SVN). Unfortunatly I am experience a few issues:
>>>
>>>  * ...deployment.model/META-INF/MANIFEST.MF contains
>>>    Bundel-Version: 1.0.0 but Eclipse searches for version
>>>    0.5.0
>>>  * ...deployment.model.edit/META-INF/ - dito
>>>  * The installableruntime.feature requires the j2ee.server.v1
>>>    plugin, but this plugin does not exist.
>>>
>>> Can you give me any hints on how to fix these issues. I am
>>> trying to write an article for a German article about the WTP
>>> adapter. So getting the adapter up and running is kinda important
>>> to me.
>>>
>>> -- 
>>> Mit freundlichen Gruessen / With kind regards
>>> DAn.I.El S. Haischt
>>>
>>> Spammers, please please send any mail to:
>>> Daniel S. Haischt <me_c@daniel.stefan.haischt.name>
>>>
>>> Want a complete signature??? Type at a shell prompt:
>>> $ > finger -l haischt@daniel.stefan.haischt.name
>>>
>>
>>
>>
>>
>>
>>
>> -- 
>> Mit freundlichen Gruessen / With kind regards
>> DAn.I.El S. Haischt
>>
>> Spammers, please please send any mail to:
>> Daniel S. Haischt <me_c@daniel.stefan.haischt.name>
>>
>> Want a complete signature??? Type at a shell prompt:
>> $ > finger -l haischt@daniel.stefan.haischt.name
>>
> 
> 
> !DSPAM:43b53c88797971594113294!
> 
> 


-- 
Mit freundlichen Gruessen / With kind regards
DAn.I.El S. Haischt

Spammers, please please send any mail to:
Daniel S. Haischt <me_c@daniel.stefan.haischt.name>

Want a complete signature??? Type at a shell prompt:
$ > finger -l haischt@daniel.stefan.haischt.name


Mime
View raw message