geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <eljo...@gmail.com>
Subject Re: Java Adventure Builder Reference application, deployment/build issues
Date Mon, 12 Dec 2005 15:50:59 GMT
Jakob Færch (Trifork) wrote:
> I guess I'm in dire need of some help with the (new?) build process.

Hi Jakob,

It seems that the new build process is a very hot topic recently. It's 
not yet described in the wiki and thus scratching your head is of a 
little help when in trouble ;)

To be honest I have tried to avoid moving to the new build procedure as 
long as possible and didn't do anything with it. I remember that right 
before the assembly module was cut off (2 days ago or so) I could build 
Geronimo from the latest sources and worked with it. Not much, so if I 
had had to upgrade yet, I would've not done anything (which is partialy 
true nonetheless).

So, we're both in the same step.

> After running
>   maven m:clean m:clean-repo new
> in the source root, the build produces (among others) a distribution
> named geronimo-jetty-j2ee-1.0-SNAPSHOT.zip (in
> ~/.maven/repository/geronimo/distributions).

True.

> This makes the unpackServer maven goal unhappy, so I the jetty-j2ee to
> geronimo-1.0-SNAPSHOT.zip (in the maven repository) to make unpackServer
> happy.

Take a look at magicGBall sample app. I saw several differences between 
it and ab, which may be of help.

> I tried running maven m:default in the source root, but that didn't
> produce anything in ~/.maven/repository/distributions.

Why did you do that at all?

> I copied the dependency on the javamail-spec from the "main" project.pom.
> The one in sandbox/adventurebuilder seemed to inherit a
> geronimo_spec_javamail_version=1.0 from etc/project.propertis which
> isn't healthy anymore.

Why? I thought that 1.0 is the latest version of any spec.

> While trying to distribute the application (running maven -o in
> sandbox/adventurebuilder) the deployer doesn't seem to recognize the
> --offline option. This might be caused by my tinkering around with the
> distribution files, so I guess I'd try to fix the above first.

I remember very vaguely that offline might not work. Try starting a 
server and distribute then.

> My repository is at version 356264; I'd expect this to be on the trunk, 
> not on the 1.0 branch, and I guess the trunk is where we wanna be, 
> considering the AB issue has been re-scheduled to 1.1.

Right.

> Would you please correct me if I'm wrong regarding which branch to use?

HEAD.

> So in short, could anyone (Jacek, maybe?) do anything to help me build
> Geronimo in a form compatible with the deployment code in
> sandbox/adventurebuilder.

Sure. I won't be available till 9 PM. I hope to find some time tonight 
to work it out.

> Just as welcome would be some instructions on how to avoid building the
> server altogether; if I just remove all geronimo stuff from my local
> repository and run maven -o in sandbox/adventurebuilder, the
> unpackServer goal fails due to the distributions snapshop not being
> present. 

Absolutely right. You'd be better off doing it online so that you won't 
have to build Geronimo yourself and download necessary dependencies as 
needed.

> Perhaps all that is needed is some maven dependency, but I have
> not been able to figure out which.

Take a look at samples and copy necessary parts. It hasn't changed much, 
I hope.

Keep up your excellent work! As long as you're working on it, I'm pretty 
confident that it'll be deployed properly soon.

> Jakob

Jacek

Mime
View raw message