geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Java Adventure Builder Reference 1.0.3 webapp deployed
Date Thu, 08 Dec 2005 16:38:35 GMT

On Dec 8, 2005, at 6:45 AM, Jakob Færch (Trifork) wrote:

> Jakob Færch (Trifork) wrote:
>> Nevertheless, when starting the server, none of the web service  
>> endpoint beans are able to start. As an example, for the  
>> CreditCardEndpointBean the following appears in the log:
>> 13:06:11,032 DEBUG [GBeanSingleReference] Waiting to start  
>> geronimo.server: 
>> name=CreditCardEndpointBean,J2EEServer=geronimo,J2EEApplication=org/ 
>> apache/geronimo/Bank1.0.3,j2eeType=WSLink,J2EEModule=null because no  
>> targets are running for reference WebServiceContainer matching the  
>> patterns  
>> geronimo.server:J2EEApplication=null,J2EEModule=org/apache/geronimo/ 
>> Jetty,J2EEServer=geronimo,j2eeType=GBean,name=JettyWebContainer and  
>> then at the end of the startup:
>> 13:06:26,725 WARN  [SilentStartupMonitor] Unable to start  
>> geronimo.server: 
>> name=CreditCardEndpointBean,J2EEServer=geronimo,J2EEApplication=org/ 
>> apache/geronimo/Bank1.0.3,j2eeType=WSLink,J2EEModule=null (starting)
>> I guess this means that the bean didn't start ;-) It doesn't answer  
>> on the address (http://localhost:8080/webservice/CreditCardService)  
>> specified in the deployment descriptor.
>> [*Q3]
>> Have you got any ideas on how to make the beans start?
>> I notice the J2EEModule=org/apache/geronimo/Jetty in the reference  
>> matching string in the first log entry. The jetty configuration  
>> reported by deployer.jar's list-modules is named  
>> geronimo/jetty/1.0-SNAPSHOT/car.

This is a bug, I've opened GERONIMO-1313 to track it.  I've fixed it in  
head, and will fix 1.0 shortly after I get it checked out.
>> Could this be related to Q2 on how to get to run on a server with  
>> "org/apache/geronimo"-naming style for configurations?
>
> The issue seems very similar to the problem Jacek faced in
> <http://www.nabble.com/WARN-SilentStartupMonitor-Unable-to-start-...- 
> %28starting%29-t515844.html#a1395857>
>
> But I am not able to figure out the connection; the reference for  
> WebServiceContainer must be defined in some GBean - there's no such  
> reference in the ear plan I'm trying to deploy (unless it's some  
> default reference from any ear that includes a web service exposed  
> EJB).

the reference is in "listener" in the openejb builder.  This tells the  
openejb builder how to hook up ejb web services to a web container.

thanks
david jencks

>
> I've been trying to get the deployer scripts to use my M5 build, but  
> am running into all sorts of maven problems. I will continue to try  
> later today.
>
> Kindly, Jakob
>


Mime
View raw message