geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dain Sundstrom (JIRA)" <...@geronimo.apache.org>
Subject [jira] Created: (GERONIMO-1303) Security configuration upgrade XML processing is not being executed
Date Tue, 06 Dec 2005 22:37:08 GMT
Security configuration upgrade XML processing is not being executed
-------------------------------------------------------------------

         Key: GERONIMO-1303
         URL: http://issues.apache.org/jira/browse/GERONIMO-1303
     Project: Geronimo
        Type: Bug
    Versions: 1.0    
    Reporter: Dain Sundstrom
 Assigned to: David Jencks 
     Fix For: 1.1


The code that automatically upgrades the M5 security configuration is not being executed.
 This means that m5 security configuration won't run in 1.0.  You will see the following exception
when this problem occurs:

[java] Deployer operation failed: org.apache.xmlbeans.XmlException: Invalid deployment descriptor:
[error: cvc-complex-type.3.2.1: Attribute not allowed (no wildcards allowed): realm-name in
element default-principal@http://geronimo.apache.org/xml/ns/security-1.1]
    [java] Descriptor: <xml-fragment configId="bar" clientConfigId="W2JBAT_appclient_vehicle/W2JBAT_appclient_vehicle_client"
clientParentId="geronimo-cts/client-security/1.0-SNAPSHOT/car" xmlns:nam="http://geronimo.apache.org/xml/ns/naming-1.0"
xmlns:sec="http://geronimo.apache.org/xml/ns/security-1.1">


If we don't get this into 1.0, we should just consider removing the code.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message