geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Bonner <bkbon...@gmail.com>
Subject Re: error in geronimo-connector-1.0.xsd
Date Tue, 29 Nov 2005 16:22:42 GMT
Jeff, I disabled the svn plugin revalidated the schema and the error
is still there.  I'll follow the thread.  Thanks again for the link.

Brian
On 11/29/05, Brian Bonner <bkbonner@gmail.com> wrote:
> Hi Jeff, I'm seeing the error in eclipse.  I built it from the command
> line.  I have the subversion plugin and Eclipse 3.1.1 with WTP 1.0M9.
>
> I'll try disabling the subversion plugin to see if that clears things
> up.  Thanks.
>
> Brian
>
> On 11/28/05, Jeff Genender <jgenender@apache.org> wrote:
> > I don't think you want to import this...the 1998 schema is supposed to
> > be redirected to the 2001 version.  It should already be imported from
> > the reference to http://www.w3.org/2001/XMLSchema at he top.
> >
> > Are you having problems building from the command liine or from within
> > Eclipse.
> >
> > Apparently there seems to be an issue in Eclipse with the subversion
> > plugin that causes.  I have not looked heavily into this issue...it can
> > be found here:
> >
> > http://www.eclipse.org/newsportal/article.php?id=1390&group=eclipse.technology.xsd
> >
> > Jeff
> >
> > Sachin Patel wrote:
> > > Yes, I see this validation error as well. There is a similar error also
> > > with geronimo-security-1.0.xsd.  There is already an existing jira
> > > opened for this.  In the tools, this problem prevents EMF code
> > > generation from completing and as a workaround I patch the schema prior
> > > to codegen by including the following import for
> > > geronimo-connector-1.0.xsd.
> > >
> > > <xs:import namespace="http://www.w3.org/XML/1998/namespace"
> > > schemaLocation="xml.xsd"/>
> > >
> > >
> > > Brian Bonner wrote:
> > >> I'm getting an error in the geronimo-connector-1.0.xsd, but I'm not
> > >> sure if it's because of Eclipse's WTP or something else.
> > >>
> > >> here's the error:
> > >>
> > >> src-resolve.4.2: Error resolving component 'xml:lang'. It was detected
> > >> that 'xml:lang' is in namespace
> > >> 'http://www.w3.org/XML/1998/namespace', but components from this
> > >> namespace are not referenceable from schema document
> > >> 'file:///C:/workspace_paraware/testschema/schema/geronimo-connector-1.0.xsd'.
> > >>
> > >> If this is the incorrect namespace, perhaps the prefix of 'xml:lang'
> > >> needs to be changed. If this is the correct namespace, then an
> > >> appropriate 'import' tag should be added to
> > >> 'file:///C:/workspace_paraware/testschema/schema/geronimo-connector-1.0.xsd'.
> > >>
> > >>
> > >> it's occurring in line 391:
> > >>
> > >>     <xs:complexType name="descriptionType">
> > >>         <xs:simpleContent>
> > >>             <xs:extension base="xs:string">
> > >>                 <xs:attribute ref="xml:lang"/>  <!--   right here
-->
> > >>             </xs:extension>
> > >>         </xs:simpleContent>
> > >>     </xs:complexType>
> > >>
> > >> Is anyone else seeing this?
> > >>
> > >> Brian
> > >>
> > >>
> >
>

Mime
View raw message