geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: error in geronimo-connector-1.0.xsd
Date Tue, 29 Nov 2005 21:46:57 GMT

On Nov 29, 2005, at 12:43 PM, Jeff Genender wrote:

> Is XMLBeans able to work with it in its current form?

Yes, and I admit to ignoring this problem since I tend to trust  
xmlbeans as the final arbiter of xml schema compliance.  I think we  
might want to ask on the xmlbeans list for their opinion.  Right now I  
don't have the bandwidth for it.

thanks
david jencks

>  IntelliJ seems to accept it.  I am just getting the error in  
> Eclipse...this is why this concerns me a little.
>
> Sachin Patel wrote:
>> Jeff,
>> According to Ed, the schema isn't valid without the import. See his  
>> response below.
>> -------- Original Message --------
>> Subject: Re: EMF can't resolve xml:lang in schema
>> Date: Tue, 29 Nov 2005 11:40:34 -0500
>> From: Ed Merks <merks@ca.ibm.com>
>> Organization: EclipseCorner
>> Newsgroups: eclipse.tools.emf
>> References: <dmhpt3$2i8$1@news.eclipse.org>
>> Sachin,
>> Imports in XML Schema are not transitive.  I.e., importing a schema  
>> that
>> in turn contains imports doesn't mean you have indirectly imported all
>> those too.  So if you use xml:lang in your schema, your schema must
>> contain an import for that.  Without that import, your schema isn't  
>> valid.
>> Jeff Genender wrote:
>>> I don't think you want to import this...the 1998 schema is supposed  
>>> to be redirected to the 2001 version.  It should already be imported  
>>> from the reference to http://www.w3.org/2001/XMLSchema at he top.
>>>
>>> Are you having problems building from the command liine or from  
>>> within Eclipse.
>>>
>>> Apparently there seems to be an issue in Eclipse with the subversion  
>>> plugin that causes.  I have not looked heavily into this issue...it  
>>> can be found here:
>>>
>>> http://www.eclipse.org/newsportal/article.php? 
>>> id=1390&group=eclipse.technology.xsd
>>>
>>> Jeff
>>>
>>> Sachin Patel wrote:
>>>> Yes, I see this validation error as well. There is a similar error  
>>>> also with geronimo-security-1.0.xsd.  There is already an existing  
>>>> jira opened for this.  In the tools, this problem prevents EMF code  
>>>> generation from completing and as a workaround I patch the schema  
>>>> prior to codegen by including the following import for  
>>>> geronimo-connector-1.0.xsd.
>>>>
>>>> <xs:import namespace="http://www.w3.org/XML/1998/namespace"  
>>>> schemaLocation="xml.xsd"/>
>>>>
>>>>
>>>> Brian Bonner wrote:
>>>>> I'm getting an error in the geronimo-connector-1.0.xsd, but I'm not
>>>>> sure if it's because of Eclipse's WTP or something else.
>>>>>
>>>>> here's the error:
>>>>>
>>>>> src-resolve.4.2: Error resolving component 'xml:lang'. It was  
>>>>> detected
>>>>> that 'xml:lang' is in namespace
>>>>> 'http://www.w3.org/XML/1998/namespace', but components from this
>>>>> namespace are not referenceable from schema document
>>>>> 'file:///C:/workspace_paraware/testschema/schema/geronimo- 
>>>>> connector-1.0.xsd'.
>>>>> If this is the incorrect namespace, perhaps the prefix of  
>>>>> 'xml:lang'
>>>>> needs to be changed. If this is the correct namespace, then an
>>>>> appropriate 'import' tag should be added to
>>>>> 'file:///C:/workspace_paraware/testschema/schema/geronimo- 
>>>>> connector-1.0.xsd'.
>>>>>
>>>>> it's occurring in line 391:
>>>>>
>>>>>     <xs:complexType name="descriptionType">
>>>>>         <xs:simpleContent>
>>>>>             <xs:extension base="xs:string">
>>>>>                 <xs:attribute ref="xml:lang"/>  <!--   right
here  
>>>>> -->
>>>>>             </xs:extension>
>>>>>         </xs:simpleContent>
>>>>>     </xs:complexType>
>>>>>
>>>>> Is anyone else seeing this?
>>>>>
>>>>> Brian
>>>>>
>>>>>
>>>
>


Mime
View raw message