geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: error in geronimo-connector-1.0.xsd
Date Mon, 28 Nov 2005 21:56:36 GMT
Yes, I see this validation error as well. There is a similar error also 
with geronimo-security-1.0.xsd.  There is already an existing jira 
opened for this.  In the tools, this problem prevents EMF code 
generation from completing and as a workaround I patch the schema prior 
to codegen by including the following import for geronimo-connector-1.0.xsd.

<xs:import namespace="http://www.w3.org/XML/1998/namespace" 
schemaLocation="xml.xsd"/>


Brian Bonner wrote:
> I'm getting an error in the geronimo-connector-1.0.xsd, but I'm not
> sure if it's because of Eclipse's WTP or something else.
>
> here's the error:
>
> src-resolve.4.2: Error resolving component 'xml:lang'. It was detected
> that 'xml:lang' is in namespace
> 'http://www.w3.org/XML/1998/namespace', but components from this
> namespace are not referenceable from schema document
> 'file:///C:/workspace_paraware/testschema/schema/geronimo-connector-1.0.xsd'.
> If this is the incorrect namespace, perhaps the prefix of 'xml:lang'
> needs to be changed. If this is the correct namespace, then an
> appropriate 'import' tag should be added to
> 'file:///C:/workspace_paraware/testschema/schema/geronimo-connector-1.0.xsd'.
>
> it's occurring in line 391:
>
>     <xs:complexType name="descriptionType">
>         <xs:simpleContent>
>             <xs:extension base="xs:string">
>                 <xs:attribute ref="xml:lang"/>  <!--   right here -->
>             </xs:extension>
>         </xs:simpleContent>
>     </xs:complexType>
>
> Is anyone else seeing this?
>
> Brian
>
>   


Mime
View raw message