geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <ge...@apache.org>
Subject Re: M5 startup without changing configs causes 'port-in-use' trouble
Date Thu, 06 Oct 2005 13:59:24 GMT
I've updated the site - I removed the installer for now until we  
decide on our path.

(I also had to update the logo for ACon to the new one...)

It will go out w/in 4 hours to public site.

geir

On Oct 6, 2005, at 9:21 AM, Kevan Miller wrote:

> I haven't seen any discussion on this. Where do things stand?  
> Personally, I don't see how we can keep an installer with this  
> behavior available for download. Users have a very reasonable  
> expectation to launch, accept default settings, and have a running  
> server. Is changing the default Tomcat ports an option? Or making  
> Tomcat/Jetty mutually exclusive unless explicitly specified?
>
> --kevan
>
> On 10/5/05, Stefan Schmidt <schmidtitc@gmail.com> wrote: Hi,
>
> I installed the new M5 with the installer (all options selected) and
> started the server without any changes to the configs. This (of  
> course -
> silly me) caused heaps of 'port already in use' exceptions for 8080  
> and
> 8443. Running G on either Tomcat or Jetty configs (or both with  
> seperate
> ports) works fine though.
>
> My problem with this that new users might not be aware of this and  
> think
> that the distrobution ships broken. Is there any chance to change  
> M5 to
> either different port settings for Tomcat/Jetty or have only one  
> running
> by default?
>
> Regards,
> Stefan Schmidt
>

-- 
Geir Magnusson Jr                                  +1-203-665-6437
geirm@apache.org



Mime
View raw message