geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Dubrov (JIRA)" <...@geronimo.apache.org>
Subject [jira] Created: (GERONIMO-1045) xml-reference in the gbean declaration located in the geronimo-application.xml does not work
Date Fri, 07 Oct 2005 03:56:47 GMT
xml-reference in the gbean declaration located in the geronimo-application.xml does not work
--------------------------------------------------------------------------------------------

         Key: GERONIMO-1045
         URL: http://issues.apache.org/jira/browse/GERONIMO-1045
     Project: Geronimo
        Type: Bug
  Components: deployment  
    Versions: 1.0-M5    
    Reporter: Ivan Dubrov


I have the following snippet in the geronimo-application.xml:

<gbean name="myapp-realm" class="org.apache.geronimo.security.realm.GenericSecurityRealm">
        <reference name="LoginService">
        	<module>org/apache/geronimo/Server</module>
        	<name>JaasLoginService</name>
        </reference>
    	<attribute name="realmName">myapp</attribute>
    	<xml-reference name="LoginModuleConfiguration">
    		<l:login-config xmlns:l="http://geronimo.apache.org/xml/ns/loginconfig">
<!-- Some omitted configuration -->
    		</l:login-config>
    	</xml-reference>
</gbean>

When I try to deploy it I get the following:

    Error: Unable to distribute myapp.ear:
    org.apache.xmlbeans.XmlException: Invalid deployment descriptor:
    [error: cvc-complex-type.2.4b: Element not allowed:
    login-config@http://geronimo.apache.org/xml/ns/deployment-1.0 in
    element
    xml-reference@http://geronimo.apache.org/xml/ns/deployment-1.0,
    error: cvc-complex-type.2.4d: Expected element(s) in element
    xml-reference@http://geronimo.apache.org/xml/ns/deployment-1.0]

And the snippet from the descriptor printed in the error message is:

        <dep:xml-reference name="LoginModuleConfiguration">
          <dep:login-config xmlns:l="http://geronimo.apache.org/xml/ns/loginconfig-1.0">

Note that login-config namespace is changed!

If I move this configuration into the stand-alone deployment plan (with <configuration>
document root), it works.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message