geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Mulder <ammul...@alumni.princeton.edu>
Subject Re: "port" element revisions
Date Sun, 18 Sep 2005 17:15:45 GMT
David J's thoughts (which are fine with me):

The extra binding-name element is required and has to go with the
other parts of the port element.  Moving it outside the port element
has the effect of requiring pairs of elements to follow each other,
which I don't like as a schema.  On the other hand the extension seems
a bit fishy even if renamed. How about introducing port-completion
that includes port and binding-name?
 
 
    <xsd:complexType name="service-completionType">
        <xsd:sequence>
            <xsd:element name="service-name" type="xsd:string"/>
            <xsd:element name="port-completion"
type="gernaming:port-completionType" maxOccurs="unbounded"/>
        </xsd:sequence>
    </xsd:complexType>
 
    <xsd:complexType name="port-completionType">
        <xsd:complexContent>
                <xsd:sequence>
                    <xsd:element name="port" type="gernaming:portType">
                    <xsd:element name="binding-name" type="xsd:string"/>
                </xsd:sequence>
        </xsd:complexContent>
    </xsd:complexType>
 
thanks
david jencks

On 9/18/05, Aaron Mulder <ammulder@alumni.princeton.edu> wrote:
> For a web services reference, we have 2 "port" elements that contain
> not quite the same thing (one has one extra element), and one "port"
> element that's totally different.  Well, changing the third (a network
> port) is not something I'm really up for at the moment.  But there are
> two options for straightening out the two very similar port types.
> One is to make the two "port" elements identical, by simply moving the
> extra element out of the one "port" that has it.  The other option is
> to change one of the "port" elements so that it's called something
> different altogether.  I've given an example below.  So far David J
> and I are split on this, so ony other opinions would be helpful.
> 
> Thanks,
>   Aaron
> 
> 
> CURRENT STATE
> 
> <service-completion>
>   <port>
>     <port-name>...
>     <protocol>...
>     <host>...
>     <port>...
>     <uri>...
>     <credentials-name>...
>     <binding-name>...   (the extra element)
>   </port>
> </service-completion>
> 
> (elsewhere)
> 
> <port>
>   <port-name>...
>   <protocol>...
>   <host>...
>   <port>...
>   <uri>...
>   <credentials-name>...
> </port>
> 
> NEW OPTION 1
> 
> <service-completion>
>   <port>
>     <port-name>...
>     <protocol>...
>     <host>...
>     <port>...
>     <uri>...
>     <credentials-name>...
>   </port>
>   <binding-name>...   (the extra element, now moved)
> </service-completion>
> 
> (elsewhere)
> 
> <port>... (same as above) ...</port>
> 
> NEW OPTION 2
> 
> <service-completion>
>   <port-completion>   (the "port" element now renamed)
>     <port-name>...
>     <protocol>...
>     <host>...
>     <port>...
>     <uri>...
>     <credentials-name>...
>     <binding-name>...
>   </port-completion>
> </service-completion>
> 
> (elsewhere)
> 
> <port>
>   <port-name>...
>   <protocol>...
>   <host>...
>   <port>...
>   <uri>...
>   <credentials-name>...
> </port>
>

Mime
View raw message