geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Mavenizing tools update...
Date Fri, 09 Sep 2005 02:26:02 GMT
Ok. submitted the patch for #9.  Once you invoke the command mentioned 
below then cd into the "assembly" project and invoke "maven".  This will 
generate geronimo-server-adapter_1.0.zip in ./target.  You can then 
extract this over your eclipse image.  (I have yet to launch eclipse 
with with the extracted zip, so you'll be the first to try :)

Sachin Patel wrote:
> Sorry... you will also need to point to your eclipse install plugin 
> locatioin (which needs to include WTP and its required projects (etc.. 
> EMF, GEF...)
>
> maven -Dgoal=jar,jar:install multiproject:goal 
> -Declipse.home.plugins=C:/eclipse/plugins/
>
> Sachin Patel wrote:
>> In order to build all the projects, from the ../eclipse-plugin/  
>> directory invoke
>>
>> maven -Dgoal=jar,jar:install multiproject:goal
>>
>> This will compile and generate the artifacts as well as deploy them 
>> into the repo.
>>
>> However, it looks like my last patch didn't include the assembly 
>> project since I forgot to run "svn add".   Thus the binary zip 
>> distribution won't get created.  So I'll open a new jira and get it 
>> commmited ASAP.
>>
>> Let me know if you have any more problems.
>>
>> Sachin.
>>
>> So the correct sequence of steps (temporaril
>>
>> Miguel A Paraz wrote:
>>> On 9/8/05, Sachin Patel <sppatel2@gmail.com> wrote:
>>>  
>>>> I still need to clean things up, lots of duplicate info that can be
>>>> pushed up into a parent POM.  Still need a top level maven.xml.  (Need
>>>> to figure out the whole mutiproject enablement).  But with this patch
>>>> everything should build and you can also creates a zip distribution.
>>>>     
>>>
>>> Hi, I'm trying out a fresh checkout. I would like to build. What's the
>>> correct sequence of steps?
>>>
>>> I tried maven in org.apache.geronimo.core but it couldn't find
>>> org.apache.geronimo.deployment.model-1.0.jar. I tried maven in
>>> org.apache.geronimo.deployment.model built it "builds successfully"
>>> and produces nothing.
>>>
>>>   
>>
>

Mime
View raw message