geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Mulder <ammul...@alumni.princeton.edu>
Subject Naming schema "port" elements
Date Wed, 03 Aug 2005 00:19:49 GMT
	So our our naming schema, when dealing with web services, has an 
unfortunate overlap with two different "port" elements that are subtlely 
different:

<service-ref>
  <service-ref-name />
  <service-completion>
    <service-name />
    <port> (def #1, portCompletionType)
      (contents of port #2)
      <binding-name />
    </port>
  </service-completion>
  <port>  (def #2)
    ...
  </port>
</service-ref>

	In other words, the first "port" element contains all the same 
stuff as the second "port" element plus one extra element.

	I think it would be preferable to have what's currently the first 
"port" look like this:

<port-completion>
  <port ... />
  <binding-name />
</port-completion>

	That way both "port" elements would be identical.

	Any objections to making this change in M5?

Thanks,
	Aaron

Mime
View raw message