geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <...@geronimo.apache.org>
Subject [jira] Commented: (GERONIMO-918) Change service-ref to use single definition of "port"
Date Thu, 25 Aug 2005 22:49:09 GMT
    [ http://issues.apache.org/jira/browse/GERONIMO-918?page=comments#action_12320058 ] 

David Jencks commented on GERONIMO-918:
---------------------------------------

I don't like what you propose.  I'd be ok with changing the port-completionType element to
be named port-completion rather than port.  WDYT?  Will you locate and fix all the plans that
are affected by this change?

> Change service-ref to use single definition of "port"
> -----------------------------------------------------
>
>          Key: GERONIMO-918
>          URL: http://issues.apache.org/jira/browse/GERONIMO-918
>      Project: Geronimo
>         Type: Bug
>   Components: deployment, webservices
>     Versions: 1.0-M4
>     Reporter: Aaron Mulder
>     Assignee: Aaron Mulder
>      Fix For: 1.0-M5

>
> Currently a web service reference has two elements named "port" that are slightly different.
 One has all the same stuff as the other, plus one extra element.  This should be changed
so both "port" elements are identical and one of them has an enclosing element containing
the "port" and the extra element.
> I think part of the issue is that both "port" elements are defined inline, and should
instead refer to a separate portType.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message