geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <...@geronimo.apache.org>
Subject [jira] Updated: (GERONIMO-717) Root configurations should use dependencies not manifest classpath. Requires built-in repository.
Date Fri, 22 Jul 2005 22:27:52 GMT
     [ http://issues.apache.org/jira/browse/GERONIMO-717?page=all ]

David Jencks updated GERONIMO-717:
----------------------------------

        Summary: Root configurations should use dependencies not manifest classpath.  Requires
built-in repository.  (was: Packaging Plugin still using geronimo-kernel-1.0-169154)
    Description: 
original summary: Packaging Plugin still using geronimo-kernel-1.0-169154

Problem:  Build fails when starting with a clean source tree and Maven repository, due to
plugins/geronimo-packaging-plugin/project.xml using hardcoded version number for geronimo-kernel-1.0-169154.

Fix:  Update plugins/geronimo-packaging-plugin/project.xml to use the default ../../etc/project.xml
like the other plugins to pick-up the current Geronimo version and to use that in the geronimo-kernel
dependency.

Fix Diff:
Index: project.xml
===================================================================
--- project.xml	(revision 209498)
+++ project.xml	(working copy)
@@ -19,16 +19,23 @@
 <!-- $Rev$ $Date$ -->
 <project>
     <pomVersion>3</pomVersion>
+    <extend>../../etc/project.xml</extend>
+
+    <!-- ===================== -->
+    <!-- Module Identification -->
+    <!-- ===================== -->
     <groupId>geronimo</groupId>
     <id>geronimo-packaging-plugin</id>
     <name>Geronimo Packaging Plugin</name>
-    <currentVersion>0.1.1</currentVersion>
 
+    <!-- ============ -->
+    <!-- Dependencies -->
+    <!-- ============ -->
     <dependencies>
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-kernel</artifactId>
-            <version>1.0-169154</version>
+            <version>${pom.currentVersion}</version>
         </dependency>
 
         <dependency>


  was:
Problem:  Build fails when starting with a clean source tree and Maven repository, due to
plugins/geronimo-packaging-plugin/project.xml using hardcoded version number for geronimo-kernel-1.0-169154.

Fix:  Update plugins/geronimo-packaging-plugin/project.xml to use the default ../../etc/project.xml
like the other plugins to pick-up the current Geronimo version and to use that in the geronimo-kernel
dependency.

Fix Diff:
Index: project.xml
===================================================================
--- project.xml	(revision 209498)
+++ project.xml	(working copy)
@@ -19,16 +19,23 @@
 <!-- $Rev$ $Date$ -->
 <project>
     <pomVersion>3</pomVersion>
+    <extend>../../etc/project.xml</extend>
+
+    <!-- ===================== -->
+    <!-- Module Identification -->
+    <!-- ===================== -->
     <groupId>geronimo</groupId>
     <id>geronimo-packaging-plugin</id>
     <name>Geronimo Packaging Plugin</name>
-    <currentVersion>0.1.1</currentVersion>
 
+    <!-- ============ -->
+    <!-- Dependencies -->
+    <!-- ============ -->
     <dependencies>
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-kernel</artifactId>
-            <version>1.0-169154</version>
+            <version>${pom.currentVersion}</version>
         </dependency>
 
         <dependency>



> Root configurations should use dependencies not manifest classpath.  Requires built-in
repository.
> --------------------------------------------------------------------------------------------------
>
>          Key: GERONIMO-717
>          URL: http://issues.apache.org/jira/browse/GERONIMO-717
>      Project: Geronimo
>         Type: Bug
>   Components: buildsystem
>     Versions: 1.0-M4
>  Environment: Clean Build
>     Reporter: Donald Woods
>  Attachments: Geronimo-717.diff
>
> original summary: Packaging Plugin still using geronimo-kernel-1.0-169154
> Problem:  Build fails when starting with a clean source tree and Maven repository, due
to plugins/geronimo-packaging-plugin/project.xml using hardcoded version number for geronimo-kernel-1.0-169154.
> Fix:  Update plugins/geronimo-packaging-plugin/project.xml to use the default ../../etc/project.xml
like the other plugins to pick-up the current Geronimo version and to use that in the geronimo-kernel
dependency.
> Fix Diff:
> Index: project.xml
> ===================================================================
> --- project.xml	(revision 209498)
> +++ project.xml	(working copy)
> @@ -19,16 +19,23 @@
>  <!-- $Rev$ $Date$ -->
>  <project>
>      <pomVersion>3</pomVersion>
> +    <extend>../../etc/project.xml</extend>
> +
> +    <!-- ===================== -->
> +    <!-- Module Identification -->
> +    <!-- ===================== -->
>      <groupId>geronimo</groupId>
>      <id>geronimo-packaging-plugin</id>
>      <name>Geronimo Packaging Plugin</name>
> -    <currentVersion>0.1.1</currentVersion>
>  
> +    <!-- ============ -->
> +    <!-- Dependencies -->
> +    <!-- ============ -->
>      <dependencies>
>          <dependency>
>              <groupId>geronimo</groupId>
>              <artifactId>geronimo-kernel</artifactId>
> -            <version>1.0-169154</version>
> +            <version>${pom.currentVersion}</version>
>          </dependency>
>  
>          <dependency>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message