geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Genender <jgenen...@savoirtech.com>
Subject Re: Change Geronimo to use Tomcat JK 1.2.13 instead of the unsupported JK 2 ?
Date Thu, 07 Jul 2005 03:53:53 GMT
That version was used because the AJP needs the JkCoyoteHandler. 
Honestly, its being used because that seemed to be the latest and 
greatest at the time (IIRC we started with Tomcat 5.0.x)...and according 
to ibibilio, it looks like its the latest one they have for the Java 
side. AFAIK, it seems to work fine.  If we can find a better one, or 
this one does not work, then lets look into it.

Are you having any problems with it?

Jeff

sissonj@insession.com wrote:
> Currently Geronimo uses the following:
> 
> tomcat_jk2_version=5.0.18
> tomcat_version=5.5.9
> 
> According to the Jakarta Tomcat Connectors page JK2 is officially 
> unsupported and has been put in maintainer mode and no further development 
> will take place 
> http://jakarta.apache.org/tomcat/connectors-doc/news/20041100.html#20041115.1 
> .
> 
> Also I read the Tomcat 5.5 documentation and it says that JK1.2 is 
> supported and "Other native connectors supporting AJP may work, but are no 
> longer supported" 
> http://jakarta.apache.org/tomcat/tomcat-5.5-doc/connectors.html. 
> 
> I'm also not clear what the jk2 version (5.0.18) really is, as the last 
> official JK2 release is 2.0.4 according to 
> http://jakarta.apache.org/tomcat/connectors-doc/news/20041100.html
> 
> Or could it be that I am being mislead by 'jk2' being i the property name 
> and it isn't really JK2 ?
> 
> John

Mime
View raw message