geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject xmlbeans versions -- please respond
Date Tue, 12 Jul 2005 20:45:26 GMT
After struggling with various attempts to use several incompatible 
versions at once, I have geronimo + openejb working with xmlbeans v2.

I've modified the plugin to install the schemas that are compiled into 
the artifact jar file under typically META-INF/schema, and these 
schemas can be extracted by the xmlbeans plugin entity resolver to 
resolve schema imports.  This dramatically reduces the use of a catalog 
and makes it possible to remove the difficult-to-keep-synchronized 
copies of geronimo schemas that are in openejb-builder/src/schema.

I've run a lot of the tck and get the same results with v2 as v1.

I'd like to commit this, well, now to at least the HEAD of geronimo and 
openejb.  Any objections?  I would like to do this very soon, such as 
this evening.

As part of the snapshot cleanup for m4 we should stop using the 1.0-DEV 
version and upgrade to something that's been released.  Choices are 
1.0.4 and 2.0.0.  I'd prefer 2, and would be more enthusiastic about 
looking for problems with that upgrade, but don't insist.

I will note that having different version of xmlbeans on two versions 
of geronimo is incredibly inconvenient, since a complete rebuild is 
needed when switching from one to the other.  It may be that having 
different versions (M4 vs SNAPSHOT) will make this problem go away, but 
I haven't tested this theory.

Opinions on moving M4 to xmlbeans2?

I've opened GERONIMO-738 to track this and to let people look at the 
patches to evaluate especially applying to M4.

thanks
david jencks


Mime
View raw message