geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Donald Woods (JIRA)" <...@geronimo.apache.org>
Subject [jira] Created: (GERONIMO-718) Assembly Plugin using 1.0-SNAPSHOT
Date Wed, 06 Jul 2005 20:39:11 GMT
Assembly Plugin using 1.0-SNAPSHOT
----------------------------------

         Key: GERONIMO-718
         URL: http://issues.apache.org/jira/browse/GERONIMO-718
     Project: Geronimo
        Type: Bug
  Components: buildsystem  
    Versions: 1.0-M4    
 Environment: Clean build
    Reporter: Donald Woods
 Attachments: Geronimo-718.diff

Problem: Build fails when starting with a clean source tree and Maven repository and not allowing
Maven to use previous Geronimo builds, due to plugins/geronimo-assembly-plugin/project.xml
using hardcoded version number for geronimo-kernel and geronimo-system of 1.0-SNAPSHOT.  This
file will have to be updated either before or right after 1.0 is released, so why not update
them now?

Fix: Update project.xml file to use the default ../../etc/project.xml like the other plugins
to pick-up the current Geronimo version and to use that in the geronimo-kernel and geronimo-system
dependency.

Fix Diff -
Index: project.xml
===================================================================
--- project.xml	(revision 209498)
+++ project.xml	(working copy)
@@ -20,21 +20,28 @@
 <project>
     <pomVersion>3</pomVersion>
     <groupId>geronimo</groupId>
+    <extend>../../etc/project.xml</extend>
+
+    <!-- ===================== -->
+    <!-- Module Identification -->
+    <!-- ===================== -->
     <id>geronimo-assembly-plugin</id>
     <name>Geronimo Assembly Plugin</name>
     <description>A plugin used to assemble a distribution of Geronimo</description>
-    <currentVersion>SNAPSHOT</currentVersion>
 
+    <!-- ============ -->
+    <!-- Dependencies -->
+    <!-- ============ -->
     <dependencies>
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-kernel</artifactId>
-            <version>1.0-SNAPSHOT</version>
+            <version>${pom.currentVersion}</version>
         </dependency>
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-system</artifactId>
-            <version>1.0-SNAPSHOT</version>
+            <version>${pom.currentVersion}</version>
         </dependency>
     </dependencies>


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message