geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <...@geronimo.apache.org>
Subject [jira] Closed: (GERONIMO-684) Wrapped document/literal do not work for empty message parts
Date Wed, 20 Jul 2005 00:30:48 GMT
     [ http://issues.apache.org/jira/browse/GERONIMO-684?page=all ]
     
David Jencks closed GERONIMO-684:
---------------------------------

    Fix Version: 1.0-M4
                 1.0-M5
     Resolution: Duplicate
      Assign To: David Jencks

I should pay more attention to bug reports.  I ran into this also and fixed it as GERONIMO-768

> Wrapped document/literal do not work for empty message parts
> ------------------------------------------------------------
>
>          Key: GERONIMO-684
>          URL: http://issues.apache.org/jira/browse/GERONIMO-684
>      Project: Geronimo
>         Type: Bug
>   Components: webservices
>     Versions: 1.0-M4
>     Reporter: Ivan Dubrov
>     Assignee: David Jencks
>      Fix For: 1.0-M4, 1.0-M5
>  Attachments: patch2
>
> If WSDL contains message parts with empty XML type, NullPointerException is thrown during
the deployment.
> Here is the relevant pieces from the WSDL:
> Piece from the schema embedded in the WSDL:
> <complexType name="methodResponseType">
>     <sequence/>
> </complexType>
> <element name=methodResponse" type="tns:methodResponseType"/>
> Snippet from the WSDL:
> <message name="SomeEndpoint_someResponse">
>     <part name="result" element="ns2:someResponse"/>
> </message>
> The attached patch shows the possible solution:
> Note that problem is that operationType.getContentModel() in the line HeavyweightOperationDescBuilder.java:231
returns null if it consists of one empty sequence. If check is added, everything works fine.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message