geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <d...@iq80.com>
Subject Re: svn commit: r191366 - in /geronimo/trunk/modules/interop: ./ src/java/org/apache/geronimo/interop/generator/ src/java/org/apache/geronimo/interop/rmi/iiop/portable/ src/test-data/ src/test-data/META-INF/ src/test-resources/
Date Mon, 20 Jun 2005 17:14:55 GMT
On Jun 19, 2005, at 3:44 PM, Jacek Laskowski wrote:

> dain@apache.org wrote:
>
>> Author: dain
>> Date: Sun Jun 19 15:25:18 2005
>> New Revision: 191366
>> URL: http://svn.apache.org/viewcvs?rev=191366&view=rev
>> Log:
>> Added portable stub generator
>> PortableStubCompiler contains utility methods to mangle overloaded  
>> operation names
>> Added name manger tests
>> Added:
>>     geronimo/trunk/modules/interop/src/java/org/apache/geronimo/ 
>> interop/rmi/iiop/portable/
>>     geronimo/trunk/modules/interop/src/java/org/apache/geronimo/ 
>> interop/rmi/iiop/portable/IiopOperation.java
>>
>
> Didn't we decide that abbreviations are written all in uppercase?  
> If so, shouldn't IiopOperation become IIOPOperation?

I don't remember, but I hope we don't keep that decision.  All  
uppercase abbrevations are quite difficult to read expecially when  
you have them one after another EJBIIOPGBean.  Also they make really  
ugly names when standard JavaBeans rules are applied eJBIIOPGBean or  
ejbiiopgBean.

-dain

Mime
View raw message