geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Panagiotis Astithas <p...@ebs.gr>
Subject Re: Nightly Releases
Date Mon, 11 Apr 2005 13:40:35 GMT
Bruce Snyder wrote:
> On Apr 10, 2005 5:18 PM, David Blevins <david.blevins@visi.com> wrote:
> 
> 
>>Let me try and get you some quick answers before my wife pulls me away from the computer.
>>
>>Using ant:checksum is cool.  Any MD5 or SHA hash is good.
>>We don't realy need PGP signatures to be part of the nightly build.  For an official
release, that part can just be done by hand.
>>The svn:mkdir isn't what we want.  There is a java version of ssh somewhere that i
know Maven is using.  Might look into that.
>>Don't add it to the exising maven.xml, use one of our plugins for a template.
>>
>>I've attached a shell script version of a nigtly build you can model after.
> 
> 
> I've been trying to get the bash script from David for nightly builds
> running on minotaur lately. What I've found is that it will run just
> fine on Linux, but not on any FreeBSD instance that I've tried so far.
> Below is the error I'm consistently receiving:
> 
> $ sh -x ./bin/nightly_release.sh 
> + RHOME=/home/bsnyder
> + PROJ=geronimo
> + BIN_DIR=modules/assembly/target
> + DIST=/home/bsnyder/dist
> + export SVN_URL=http://svn.apache.org/repos/asf/geronimo
> + export REPO_USER=dblevins
> + export REPO_DIR=/www/cvs.apache.org/repository
> + export REPO=apache.org
> + export VN=1.0
> + export RELEASE_DIR=/www/cvs.apache.org/dist/geronimo
> + wget+ grep+ sed s/[^0-9]//g
>  -q title
>  -O - http://svn.apache.org/repos/asf/geronimo/trunk
> + SVN_VERSION=160721
> + VERSION=1.0-160721
> + RELEASE_ID=geronimo-1.0-160721
> + VERSION_DIR=/www/cvs.apache.org/dist/geronimo/unstable/1.0-160721
> + echo RELEASE geronimo-1.0-160721
> RELEASE geronimo-1.0-160721
> ./bin/nightly_release.sh: 26: Syntax error: "(" unexpected
> 
> I've done a lot of shell scripting in my time, but this particular
> error has managed to completely stump me. Does anyone know what the
> issue might be?
> 
> Bruce 

The script requires bash, but you seem to be using FreeBSD's sh, which 
is not quite compatible. Perhaps you could install the bash port and try 
it again?

Cheers,
-- 
Panagiotis Astithas, PhD
R&D Manager
EBS, Electronic Business Systems Ltd.
18 Evgenidou Street, 115 25, Athens GREECE
Phone: +30 210 674 7631
Fax: +30 210 674 7601
http://www.ebs.gr

Mime
View raw message