geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <djen...@gluecode.com>
Subject Re: Bug in deployment?
Date Fri, 11 Mar 2005 06:56:48 GMT

On Mar 10, 2005, at 10:48 PM, Dondi Imperial wrote:

> David Jencks wrote:
>
>> It's a bug, I filed it as  
>> http://issues.apache.org/jira/browse/GERONIMO-606
>>
>> I'm thinking about what to do about it.
>>
>> Is there really a mismatch between the domain and server  on the 2  
>> names?  (joe/geronimo)
>
> Nope that was a typo.

good, then I think there's only one problem :-)

Can you try replacing line 51 of EarContext with this?

         j2eeContext = new J2eeContextImpl(getDomain(), getServer(), 
j2eeApplicationName == null ? NameFactory.NULL : j2eeApplicationName, 
NameFactory.J2EE_MODULE, NameFactory.NULL, null, null);

I'm not sure but it might fix the problem.  I'll investigate more 
tomorrow, right now I need some sleep.

thanks
david jencks

>
>>
>> In this particular case I think it would be a good idea to put the  
>> deployment gbeans in a separate gbean-only plan, similar to the  
>> geronimo runtime-deployer-plan.  However, even if this solves the  
>> immediate problem there is still a bug.
>>
>> Thanks for finding this.
>>
>> david jencks
>
> -- 
> Dondi Imperial
> Software Engineer
> Exist Software Labs
> 1907, The Orient Square
> Emerald Avenue, Ortigas Center
> Pasig City 1605
> Philippines
> +632.687.7653
> www.exist.com
>
>


Mime
View raw message