geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <...@geronimo.apache.org>
Subject [jira] Closed: (GERONIMO-450) GBeans should use jsr-77 naming conventions and these names should have mostly default components
Date Sun, 06 Mar 2005 02:57:54 GMT
     [ http://issues.apache.org/jira/browse/GERONIMO-450?page=history ]
     
David Jencks closed GERONIMO-450:
---------------------------------

     Resolution: Fixed
    Fix Version: 1.0-M4

Finally done!  It could use some better documentation though.

> GBeans should use jsr-77 naming conventions and these names should have mostly default
components
> -------------------------------------------------------------------------------------------------
>
>          Key: GERONIMO-450
>          URL: http://issues.apache.org/jira/browse/GERONIMO-450
>      Project: Geronimo
>         Type: Improvement
>   Components: deployment
>     Versions: 1.0-M2
>     Reporter: David Jencks
>     Assignee: David Jencks
>      Fix For: 1.0-M4

>
> Currently the usage of object names for non-j2ee-wrapping gbeans is more or less random
and confusing.  We should adopt as much of jsr-77 naming as possible for our gbeans.  Furthermore,
as little as possible of the names should be specified in the gbean xml descriptor.  Here's
a proposal:
> 1. A service module that has no parent must specify domain and server name.  This domain
and server name will be inherited by all children recursively.
> 2. All gbeans deployed from a service dd will have J2EEApplication=null and GeronimoModule=<configId>
> 3. All gbeans deployed from a j2ee module or application will have J2EEApplication set
from the application and GeronimoModule=<configId>
> 4. A gbean xml descriptor will have attributes for j2eeType and name.  We will invent
more j2eeType names as needed and prefix them with Ger or Geronimo.
> I'm inclined to remove the possibility of directly specifying the entire object name.
 If it is really needed I'd suggest the attribute be called target-name in analogy to the
usage in refs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message