geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <dsundst...@gluecode.com>
Subject Re: WARNING!! re: Request for backward-incompatible gbean plan change (related to GERONIMO-450)
Date Mon, 07 Feb 2005 17:40:38 GMT
On Feb 6, 2005, at 11:16 PM, David Jencks wrote:

> Well, I need to think about all this some more to completely 
> understand it, and I don't think we'll be implementing more generic 
> naming strategies for a couple of weeks anyway.
>
> For now, I propose:
>
> 1. replace the two "hardcoded" fields on Configuration with a map

Maybe I skimmed to fast, but what "hardcoded" fields?

> 2. go forward with my original proposal in this thread of changing 
> namePart to name and name to gbeanName in the xml gbean descriptor.  
> (was to objectName, so its not entirely my original proposal).

+1

> I think that will get the "xml interface" looking better and remove 
> the inroads of jsr-77 on the kernel.

What inroads?


On Feb 6, 2005, at 10:05 PM, Jeremy Boynes wrote:

> David Jencks wrote:
>> Do you think that the "domain" part should be forced to be the kernel
>> name?
>
> No. IIRC JSR77 has rules here for the J2EEDomain object but that is 
> just a J2EE artifact and there's no reason to constrain this in the 
> general case.

The kernel name is always the domain name.  It has been that way for a 
while now.

-dain


Mime
View raw message