Return-Path: Delivered-To: apmail-geronimo-dev-archive@www.apache.org Received: (qmail 90007 invoked from network); 10 Jan 2005 19:07:23 -0000 Received: from hermes.apache.org (HELO mail.apache.org) (209.237.227.199) by minotaur-2.apache.org with SMTP; 10 Jan 2005 19:07:23 -0000 Received: (qmail 48694 invoked by uid 500); 10 Jan 2005 19:07:18 -0000 Delivered-To: apmail-geronimo-dev-archive@geronimo.apache.org Received: (qmail 48573 invoked by uid 500); 10 Jan 2005 19:07:18 -0000 Mailing-List: contact dev-help@geronimo.apache.org; run by ezmlm Precedence: bulk list-help: list-unsubscribe: list-post: Reply-To: dev@geronimo.apache.org Delivered-To: mailing list dev@geronimo.apache.org Received: (qmail 48439 invoked by uid 99); 10 Jan 2005 19:07:17 -0000 X-ASF-Spam-Status: No, hits=0.0 required=10.0 tests= X-Spam-Check-By: apache.org Received: from ajax-1.apache.org (HELO ajax.apache.org) (192.87.106.226) by apache.org (qpsmtpd/0.28) with ESMTP; Mon, 10 Jan 2005 11:07:16 -0800 Received: from ajax.apache.org (ajax.apache.org [127.0.0.1]) by ajax.apache.org (8.12.11/8.12.11) with ESMTP id j0AJ7Du9019892 for ; Mon, 10 Jan 2005 20:07:13 +0100 Message-ID: <1811995776.1105384033666.JavaMail.jira@ajax.apache.org> Date: Mon, 10 Jan 2005 20:07:13 +0100 (CET) From: "David Jencks (JIRA)" To: dev@geronimo.apache.org Subject: [jira] Commented: (GERONIMO-450) GBeans should use jsr-77 naming conventions and these names should have mostly default components In-Reply-To: <2017675152.1099849712402.JavaMail.apache@nagoya> Mime-Version: 1.0 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit X-Virus-Checked: Checked X-Spam-Rating: minotaur-2.apache.org 1.6.2 0/1000/N [ http://issues.apache.org/jira/browse/GERONIMO-450?page=comments#action_57482 ] David Jencks commented on GERONIMO-450: --------------------------------------- I've implemented some parts of this. gbean xml config can specify namePart and type for name and j2eeType portions of the generated ObjectName, or can specify the entire object name as name. Extracting the domain and server from the top-level plan is not yet implemented. An additional desirable feature would be replacing literal object names in references by the parts that differ from the context. This would involve either two elements for reference patterns or a backward incompatible change to avoid mixed context. > GBeans should use jsr-77 naming conventions and these names should have mostly default components > ------------------------------------------------------------------------------------------------- > > Key: GERONIMO-450 > URL: http://issues.apache.org/jira/browse/GERONIMO-450 > Project: Apache Geronimo > Type: Improvement > Components: deployment > Versions: 1.0-M2 > Reporter: David Jencks > Assignee: David Jencks > > Currently the usage of object names for non-j2ee-wrapping gbeans is more or less random and confusing. We should adopt as much of jsr-77 naming as possible for our gbeans. Furthermore, as little as possible of the names should be specified in the gbean xml descriptor. Here's a proposal: > 1. A service module that has no parent must specify domain and server name. This domain and server name will be inherited by all children recursively. > 2. All gbeans deployed from a service dd will have J2EEApplication=null and GeronimoModule= > 3. All gbeans deployed from a j2ee module or application will have J2EEApplication set from the application and GeronimoModule= > 4. A gbean xml descriptor will have attributes for j2eeType and name. We will invent more j2eeType names as needed and prefix them with Ger or Geronimo. > I'm inclined to remove the possibility of directly specifying the entire object name. If it is really needed I'd suggest the attribute be called target-name in analogy to the usage in refs. -- This message is automatically generated by JIRA. - If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa - If you want more information on JIRA, or have a bug to report see: http://www.atlassian.com/software/jira