geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From siss...@insession.com
Subject Re: [jira] Commented: (GERONIMO-541) Upgrade ActiveMQ to 2.0 and use JDBC as default persistence option
Date Mon, 24 Jan 2005 04:10:20 GMT
Mark,

David's suggestion works, but I still think there is a problem that needs 
to be fixed (patch attached to JIRA issue) so that Geronimo and all 
associated projects can be built successfully using the instructions on 
the Wiki.

The file:

 
geronimo\activemq\modules\gbean\src\java\org\codehaus\activemq\store\jdbc\JDBCPersistenceAdapterGBean.java



requires:

 
geronimo\activemq\activemq\stores\jdbc\src\java\org\codehaus\activemq\store\jdbc\
JDBCPersistenceAdapterGBean.java

Therefore shouldn't geronimo\project.properties have the following file 
added to its maven.multiproject.includes property (what my patch does): ? 

    activemq/stores/jdbc/project.xml


Can someone explain why David's suggested commands work, but the commands 
I am using (that the Wiki also has) don't ?

Thanks,

John


Mark <delafran_j2ee@hotmail.com> wrote on 21/01/2005 06:05:43 PM:

> John,
> 
> I had this problem last week too.  David Blevins posted a message about 
> doing:
> 
> ------------
> maven clean  default
> Make sure you are online when doing the build
> ------------
> 
> I ended up doing:
> 
> maven clean
> maven  -Dmaven.test.skip=true -Dmaven.itest.skip=true default
> 
> Mark
> 
> John Sisson (JIRA) wrote:
> 
> >     [ http://issues.apache.org/jira/browse/GERONIMO-541?
> page=comments#action_57872 ]
> > 
> >John Sisson commented on GERONIMO-541:
> >--------------------------------------
> >
> >With the following build commands:
> >
> >maven m:update
> >maven m:rebuild -Dmaven.test.skip=true -Dmaven.itest.skip=true
> >
> >I have been having this compile error for a few days now:
> >
> >D:
> 
\Projects\J2EE\geronimo\activemq\modules\gbean\src\java\org\codehaus\activemq\store\jdbc\JDBCPersistenceAdapterGBean.
> java:97: cann
> >ot resolve symbol
> >symbol  : method createTransactionStore ()
> >location: class org.codehaus.activemq.store.jdbc.JDBCPersistenceAdapter
> >        return pa.createTransactionStore();
> >                 ^
> >
> >I have attached a patch that fixes the problem.
> >
> > 
> >
> >>Upgrade ActiveMQ to 2.0 and use JDBC as default persistence option
> >>------------------------------------------------------------------
> >>
> >>         Key: GERONIMO-541
> >>         URL: http://issues.apache.org/jira/browse/GERONIMO-541
> >>     Project: Apache Geronimo
> >>        Type: Improvement
> >>  Components: ActiveMQ
> >>    Versions: 1.0-M3
> >>    Reporter: Hiram Chirino
> >>    Assignee: Hiram Chirino
> >>     Fix For: 1.0-M4
> >> 
> >>
> >
> > 
> >
> >
> >
> > 
> >
> 


Mime
View raw message