geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Getting started with Geronimo
Date Sun, 16 Jan 2005 23:31:19 GMT
I've fixed it enough so it works on my machine, and checked everything  
in :-)  There were quite a few problems.

Let us know if you continue to have problems.

Some comments inline
On Jan 15, 2005, at 9:20 PM, Nathan Peles wrote:

> Hi,
>
> I'm just getting started with Geronimo, but am having some trouble  
> getting
> it up & running.
>
> I've checked out the source with subversion and run maven to compile  
> it (all
> seemed to work ok.)
>
> I then tried to run the server:
>
>   cd modules/assembly/target/geronimo-1.0-SNAPSHOT
>
>   java -jar bin/server.jar org/apache/geronimo/Server
>
This will work if you are starting an already distributed  
configuration, such as the debug console.  However, if you want to  
deploy anything in addition, you should either use

java -jar bin/server.jar
which will start all the configurations in the persistent configuration  
list (var/config/config-list.txt)

or
java -jar bin/server.jar org/apache/geronimo/RuntimeDeployer

The Server configuration no longer contains any deployment gbeans, so  
just org/apache/geronimo/Server would leave you unable to deploy  
anything.

> (the server starts up ok.)
>
>   java -jar bin/deployer.jar org/apache/geronimo/DebugConsole
>

I think you need to include the command you want to execute

java -jar bin/deployer.jar start org/apache/geronimo/DebugConsole

or

java -jar bin/deployer.jar --user system --password manager start  
org/apache/geronimo/DebugConsole


Again, many thanks for pointing out these problems.  I've installed  
something so geronimo will print out non-started gbeans when the server  
is started which will help make some of these problems more evident in  
the future.

david jencks

> This prompts me for a username & password (I used system/manager)  
> however I
> get the following error:
>
> "Error: Unable to connect to server: Invalid login."
>
> I had a look in the file "var/security/users.properties" & it does  
> list that
> login.
>
> I also tried starting up the server with the DebugConsole enabled  
> using the
> following command:
>
> "java -jar bin/server.jar org/apache/geronimo/Server
> org/apache/geronimo/DebugConsole"
>
> However it failed with the following error:
>
> org.apache.geronimo.kernel.config.NoSuchConfigException: No  
> configuration
> with id: org/apache/geronimo/DebugConsole
>         at
> org.apache.geronimo.kernel.config.ConfigurationManagerImpl.load(Configu 
> ratio
> nManagerImpl.java:129)
>         at
> org.apache.geronimo.kernel.config.ConfigurationManagerImpl.loadRecursiv 
> e(Con
> figurationManagerImpl.java:167)
>         at org.apache.geronimo.system.main.Daemon.main(Daemon.java:148)
>
>
> It looks like the DebugConsole config is missing(?) however I'm still  
> new to
> the Geronimo directory structure, so I was hoping one of you guys  
> could help
> me with this error?
>
> -Nathan
>


Mime
View raw message