geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Mulder <ammul...@alumni.princeton.edu>
Subject Re: No Deployer Found error
Date Thu, 02 Dec 2004 23:12:10 GMT
	For the current SVN HEAD, you need to make sure the
org/apache/geronimo/RuntimeDeployer service is running.  Try "java -jar 
bin/deployer.jar list-modules --started" (this is not applicable to M3)

	Also, you should validate your Geronimo deployment plans and make 
sure they're correct.

	Also, the correct EAR deployment plan file name is 
META-INF/geronimo-application.xml  (e.g. not plural)

Aaron

On Thu, 2 Dec 2004, Hari Kodungallur wrote:

> Hi,
> 
> I am getting the following error when I try to deploy an ear (M3
> release).
> 
>  Server reports: No deployer found:,<modulepath/modulename>
> org.apache.geronimo.deployment.DeploymentException: No deployer found:,
> <modulepath/modulename>
>         at
> org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:140)
>         at
> org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:60)
>         at
> org.apache.geronimo.deployment.Deployer$$FastClassByCGLIB$$734a235d.invoke(<generated>)
>         at net.sf.cglib.reflect.FastMethod.invoke(FastMethod.java:87)
>         at
> org.apache.geronimo.gbean.jmx.FastMethodInvoker.invoke(FastMethodInvoker.java:38)
> ...
> ...
> ...
> 
> 
> A fresh checkout and build produces the same result -- this time with
> the message: Syntax error in deployment plan or no deployer service
> available (currently I can't tell the difference):....
> This message, looking at the source code, is essentially same as the
> above message from M3 release
> 
> I do have the geronimo-applications.xml and the openejb-jar.xml files in
> their respective ear/jar files.
> 
> Anybody else seen this before? I appreciate any help on this problem
> 
> Thanks much!
> -Hari
> 
> 

Mime
View raw message