geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <dsundst...@gluecode.com>
Subject Re: build freezes
Date Mon, 06 Dec 2004 18:36:45 GMT
I've gotten that a few times... it is because you have a defunct java  
process running in the background and the client is attempting to  
connect to it.

-dain

--
Dain Sundstrom
Chief Architect
Gluecode Software
310.536.8355, ext. 26

On Dec 6, 2004, at 10:14 AM, David Jencks wrote:

> twice now I've had the build freeze on me during assembly.  This time  
> I got a thread dump, and this might be the relevant portion:
>
>  [java] "main" prio=5 tid=0x00500df0 nid=0x1801200 runnable  
> [f07ff000..f0800328]
>     [java]      at java.io.FileInputStream.readBytes(Native Method)
>     [java]      at  
> java.io.FileInputStream.read(FileInputStream.java:194)
>     [java]      at  
> java.io.BufferedInputStream.read1(BufferedInputStream.java:220)
>     [java]      at  
> java.io.BufferedInputStream.read(BufferedInputStream.java:277)
>     [java]      - locked <0x65714a50> (a java.io.BufferedInputStream)
>     [java]      at  
> sun.nio.cs.StreamDecoder$CharsetSD.readBytes(StreamDecoder.java:408)
>     [java]      at  
> sun.nio.cs.StreamDecoder$CharsetSD.implRead(StreamDecoder.java:450)
>     [java]      at  
> sun.nio.cs.StreamDecoder.read(StreamDecoder.java:182)
>     [java]      - locked <0x65723530> (a java.io.InputStreamReader)
>     [java]      at  
> java.io.InputStreamReader.read(InputStreamReader.java:167)
>     [java]      at java.io.BufferedReader.fill(BufferedReader.java:136)
>     [java]      at  
> java.io.BufferedReader.readLine(BufferedReader.java:299)
>     [java]      - locked <0x65723530> (a java.io.InputStreamReader)
>     [java]      at  
> java.io.BufferedReader.readLine(BufferedReader.java:362)
>     [java]      at  
> org.apache.geronimo.deployment.cli.ServerConnection.doAuthPromptAndRetr 
> y(ServerConnection.java:198)
>     [java]      at  
> org.apache.geronimo.deployment.cli.ServerConnection.tryToConnect(Server 
> Connection.java:160)
>     [java]      at  
> org.apache.geronimo.deployment.cli.ServerConnection.<init>(ServerConnec 
> tion.java:123)
>     [java]      at  
> org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java: 
> 111)
>     [java]      at  
> org.apache.geronimo.deployment.cli.DeployTool.main(DeployTool.java: 
> 254)
>     [java]
>
>
> any ideas?
>
> I haven't taken this too seriously yet since I typically have many  
> java processes running at once and some of them have debugging enabled  
> and have been suspended for a long time so I'm inclined to suspect a  
> vm bug, but I wonder if anyone else has seen anything like this.
>
> thanks
> david jencks


Mime
View raw message