geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hari Kodungallur <hkodungal...@spikesource.com>
Subject Re: No Deployer Found error
Date Thu, 02 Dec 2004 23:42:17 GMT
I tried both

java -jar bin/deployer.jar --user system --password manager deploy
~/Myapp/myapp.ear

and

java -jar bin/deployer.jar --user system --password manager deploy
~/Myapp/myapp.ear ~/Myapp/META-INF/geronimo-application.xml


Please let me know if I need to use any other option.

Thanks much!
-Hari



On Thu, 2004-12-02 at 15:42, Aaron Mulder wrote:
> 	Is the server running when you try this?  Can you provide the 
> exact command line you're using?
> 
> Aaron
> 
> On Thu, 2 Dec 2004, Hari Kodungallur wrote:
> > Sorry for the typo. I do have it as geronimo-application.xml.
> > And I verified using the list-modules that RuntimeDeployer is running.
> > 
> > I am wondering how RuntimeDeployer and J2EE Deployer are related. The
> > deployer.jar's manifest files refers to J2EEDeployer. Do we need to
> > start that configuration?
> > 
> > Thanks much!
> > -Hari
> > 
> > 
> > 
> > On Thu, 2004-12-02 at 15:12, Aaron Mulder wrote:
> > > 	For the current SVN HEAD, you need to make sure the
> > > org/apache/geronimo/RuntimeDeployer service is running.  Try "java -jar 
> > > bin/deployer.jar list-modules --started" (this is not applicable to M3)
> > > 
> > > 	Also, you should validate your Geronimo deployment plans and make 
> > > sure they're correct.
> > > 
> > > 	Also, the correct EAR deployment plan file name is 
> > > META-INF/geronimo-application.xml  (e.g. not plural)
> > > 
> > > Aaron
> > > 
> > > On Thu, 2 Dec 2004, Hari Kodungallur wrote:
> > > 
> > > > Hi,
> > > > 
> > > > I am getting the following error when I try to deploy an ear (M3
> > > > release).
> > > > 
> > > >  Server reports: No deployer found:,<modulepath/modulename>
> > > > org.apache.geronimo.deployment.DeploymentException: No deployer found:,
> > > > <modulepath/modulename>
> > > >         at
> > > > org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:140)
> > > >         at
> > > > org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:60)
> > > >         at
> > > > org.apache.geronimo.deployment.Deployer$$FastClassByCGLIB$$734a235d.invoke(<generated>)
> > > >         at net.sf.cglib.reflect.FastMethod.invoke(FastMethod.java:87)
> > > >         at
> > > > org.apache.geronimo.gbean.jmx.FastMethodInvoker.invoke(FastMethodInvoker.java:38)
> > > > ...
> > > > ...
> > > > ...
> > > > 
> > > > 
> > > > A fresh checkout and build produces the same result -- this time with
> > > > the message: Syntax error in deployment plan or no deployer service
> > > > available (currently I can't tell the difference):....
> > > > This message, looking at the source code, is essentially same as the
> > > > above message from M3 release
> > > > 
> > > > I do have the geronimo-applications.xml and the openejb-jar.xml files
in
> > > > their respective ear/jar files.
> > > > 
> > > > Anybody else seen this before? I appreciate any help on this problem
> > > > 
> > > > Thanks much!
> > > > -Hari
> > > > 
> > > > 
> > 
> > 


Mime
View raw message