geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Mulder <ammul...@alumni.princeton.edu>
Subject Re: svn commit: rev 55519 - in geronimo/trunk: . etc modules/assembly
Date Mon, 01 Nov 2004 21:49:52 GMT
	To follow up, I think we could fix this by adding a block for 
axis-wsdl4j to project.xml with repository=true.  But if I look at 
modules/assembly/src/plan/j2ee-server-plan.xml I don't see any Axis 
dependencies in there, so I don't understand why Geronimo thinks wsdl4j is 
a dependency of org/apache/geronimo/Server.  Can you post the 
j2ee-server-plan.xml that you're using?

Aaron

On Mon, 1 Nov 2004, David Blevins wrote:
> Aaron, you added Axis to the default plan, but know I get a failed dependency starting
Geronimo.
> 
> 
>     [java] org.apache.geronimo.deployment.DeploymentException: org.apache.geronimo.kernel.config.InvalidConfigException:
Invalid GBean configuration for geronimo.config:name="org/apache/geronimo/Server"
>     [java]      at org.apache.geronimo.deployment.DeploymentContext.<init>(DeploymentContext.java:125)
>     [java]      at org.apache.geronimo.j2ee.deployment.EARContext.<init>(EARContext.java:50)
>     [java]      at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.buildConfiguration(EARConfigBuilder.java:271)
>     [java]      at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:174)
>     [java]      at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:83)
>     [java]      at org.apache.geronimo.kernel.Kernel.invoke(Kernel.java:235)
>     [java]      at org.apache.geronimo.system.main.CommandLine.<init>(CommandLine.java:106)
>     [java]      at org.apache.geronimo.system.main.CommandLine.main(CommandLine.java:64)
>     [java] Caused by: org.apache.geronimo.kernel.config.InvalidConfigException: Invalid
GBean configuration for geronimo.config:name="org/apache/geronimo/Server"
>     [java]      at org.apache.geronimo.kernel.Kernel.startGBean(Kernel.java:310)
>     [java]      at org.apache.geronimo.deployment.DeploymentContext.<init>(DeploymentContext.java:123)
>     [java]      ... 7 more
>     [java] Caused by: org.apache.geronimo.kernel.repository.MissingDependencyException:
Unable to resolve dependency axis/jars/axis-wsdl4j-1.2-RC1.jar
>     [java]      at org.apache.geronimo.kernel.config.Configuration.doStart(Configuration.java:160)
>     [java]      at org.apache.geronimo.kernel.Kernel.invoke(Kernel.java:235)
>     [java]      at org.apache.geronimo.kernel.Kernel.invoke(Kernel.java:230)
>     [java]      at org.apache.geronimo.kernel.Kernel.startGBean(Kernel.java:308)
>     [java]      ... 8 more
> 
> 
> -David
> 
> 
> On Mon, Oct 25, 2004 at 06:09:15PM -0000, ammulder@apache.org wrote:
> > Author: ammulder
> > Date: Mon Oct 25 11:09:15 2004
> > New Revision: 55519
> > 
> > Modified:
> >    geronimo/trunk/dependencies.xml
> >    geronimo/trunk/etc/version-info.ent
> >    geronimo/trunk/modules/assembly/project.xml
> > Log:
> > 1) Remove JAXB from dependency list
> > 2) Add Oro to dependency list
> > 3) Add Axis to default assembly repository
> > 
> > 
> > Modified: geronimo/trunk/dependencies.xml
> > ==============================================================================
> > --- geronimo/trunk/dependencies.xml	(original)
> > +++ geronimo/trunk/dependencies.xml	Mon Oct 25 11:09:15 2004
> > @@ -276,6 +276,7 @@
> >              <version>&javacc-version;</version>
> >              <jar>JavaCC.zip</jar>
> >          </dependency>
> > +<!-- AMM: Axis module does not seem to use JAXB any more
> >          <dependency>
> >              <groupId>jaxb-ri</groupId>
> >              <artifactId>jaxb-api</artifactId>
> > @@ -306,6 +307,7 @@
> >              <artifactId>xsdlib</artifactId>
> >              <version>&jaxb-ri-version;</version>
> >          </dependency>
> > +-->
> >          <dependency>
> >              <groupId>jdbm</groupId>
> >              <artifactId>jdbm</artifactId>
> > @@ -407,6 +409,11 @@
> >              <groupId>openorb</groupId>
> >              <artifactId>openorb-tools</artifactId>
> >              <version>&openorb-version;</version>
> > +        </dependency>
> > +        <dependency>
> > +            <groupId>oro</groupId>
> > +            <artifactId>oro</artifactId>
> > +            <version>&oro-version;</version>
> >          </dependency>
> >          <dependency>
> >              <groupId>p2psockets</groupId>
> > 
> > Modified: geronimo/trunk/etc/version-info.ent
> > ==============================================================================
> > --- geronimo/trunk/etc/version-info.ent	(original)
> > +++ geronimo/trunk/etc/version-info.ent	Mon Oct 25 11:09:15 2004
> > @@ -74,6 +74,7 @@
> >  <!ENTITY mockobjects-version "0.09">
> >  <!ENTITY mx4j-version "2.0.1">
> >  <!ENTITY openorb-version "1.4.0-BETA2">
> > +<!ENTITY oro-version "2.0.8">
> >  <!ENTITY p2psockets-version "1.1.2">
> >  <!ENTITY regexp-version "1.3">
> >  <!ENTITY spring-version "1.0.1">
> > 
> > Modified: geronimo/trunk/modules/assembly/project.xml
> > ==============================================================================
> > --- geronimo/trunk/modules/assembly/project.xml	(original)
> > +++ geronimo/trunk/modules/assembly/project.xml	Mon Oct 25 11:09:15 2004
> > @@ -675,6 +675,23 @@
> >  	    </properties>
> >  	</dependency>
> >  
> > +        <dependency>
> > +            <groupId>axis</groupId>
> > +            <artifactId>axis</artifactId>
> > +            <version>&axis-version;</version>
> > +            <properties>
> > +                <repository>true</repository>
> > +            </properties>
> > +        </dependency>
> > +
> > +        <dependency>
> > +            <groupId>axis</groupId>
> > +            <artifactId>commons-discovery</artifactId>
> > +            <version>&axis-commons-discovery-version;</version>
> > +            <properties>
> > +                <repository>true</repository>
> > +            </properties>
> > +        </dependency>
> >      </dependencies>
> >  
> >  </project>
> 

Mime
View raw message