geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <dsundst...@gluecode.com>
Subject Re: Weird Build Failure
Date Fri, 05 Nov 2004 22:55:51 GMT
I just did a full update and rebuild.  My guess is the you were out of  
skew with OpenEJB.

-dain

--
Dain Sundstrom
Chief Architect
Gluecode Software
310.536.8355, ext. 26

On Nov 5, 2004, at 2:06 PM, Aaron Mulder wrote:

> 	It looks like OpenEJB references the class that was moved.  I
> speculate that the problem is that I didn't check out OpenEJB for this
> test build, and the OpenEJB JARs on the Maven repo must not have been
> udpated, so it probably works if you build OpenEJB locally and breaks  
> if
> you don't.
>
> Aaron
>
> On Fri, 5 Nov 2004, Aaron Mulder wrote:
>> 	Here's the maven stack trace (thanks for the tip Dain):
>>
>> java.lang.NoClassDefFoundError:
>> org/apache/geronimo/j2ee/deployment/j2eeobjectnames/J2eeContext
>>         at java.lang.Class.getDeclaredMethods0(Native Method)
>>         at java.lang.Class.privateGetDeclaredMethods(Class.java:1647)
>>         at java.lang.Class.getDeclaredMethod(Class.java:1254)
>>         at
>> org.apache.geronimo.gbean.GBeanInfo.getGBeanInfo(GBeanInfo.java:55)
>>         at
>> org.apache.geronimo.deployment.service.GBeanBuilder.<init>(GBeanBuilde 
>> r.java:52)
>>         at
>> org.apache.geronimo.deployment.service.GBeanHelper.addGbean(GBeanHelpe 
>> r.java:31)
>>         at
>> org.apache.geronimo.deployment.service.ServiceConfigBuilder.buildConfi 
>> guration(ServiceConfigBuilder.java:110)
>>         at
>> org.apache.geronimo.deployment.Bootstrap.bootstrap(Bootstrap.java:186
>> ...
>>
>> Aaron
>>
>> On Fri, 5 Nov 2004, Alan D. Cabrera wrote:
>>> I have the same problem.
>>>
>>>
>>> Regards,
>>> Alan
>>>
>>> 	-----Original Message-----
>>> 	From: Aaron Mulder [mailto:ammulder@alumni.princeton.edu]
>>> 	Sent: Fri 11/5/2004 4:23 PM
>>> 	To: dev@geronimo.apache.org
>>> 	Cc:
>>> 	Subject: Weird Build Failure
>>> 	
>>> 	
>>>
>>> 	        I just deleted my .maven and Geronimo dirs and checked out  
>>> a new
>>> 	copy and ran "maven".  It does everything OK up to assembly, and  
>>> then dies
>>> 	bootstrapping the deployer:
>>> 	
>>> 	    [echo] Preprocessing j2ee-server-plan.xml
>>> 	    [echo] Bootstrapping service deployer
>>> 	    [mkdir] Created dir:
>>> 	/home/ammulder/geronimo/modules/assembly/target/geronimo-1.0- 
>>> SNAPSHOT/bin
>>> 	    [mkdir] Created dir:
>>> 	/home/ammulder/geronimo/modules/assembly/target/geronimo-1.0- 
>>> SNAPSHOT/config-store
>>> 	
>>> 	BUILD FAILED
>>> 	File......
>>> 	/home/ammulder/.maven/cache/maven-multiproject-plugin-1.3.1/ 
>>> plugin.jelly
>>> 	Element... maven:reactor
>>> 	Line...... 217
>>> 	Column.... 9
>>> 	Unable to obtain goal [default] --
>>> 	/home/ammulder/geronimo/modules/assembly/maven.xml:208:15:
>>> 	<bootstrap:bootstrap>
>>> 	org/apache/geronimo/j2ee/deployment/j2eeobjectnames/J2eeContext
>>> 	
>>> 	        Looks like this class is in modules/j2ee -- I'm not sure  
>>> why it's
>>> 	suddenly relevant to the bootstrapper, and failing.
>>> 	
>>> 	Thanks,
>>> 	        Aaron
>>> 	
>>>
>>>
>>


Mime
View raw message