geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Commons Logging problem?
Date Thu, 04 Nov 2004 11:42:12 GMT
Aaron,

Here's my paste: http://rafb.net/paste/results/I89rnj81.html. If you
look closely, there's some problem loading commons logging stuff in
your environment.

24:   [java] [DEBUG] Finding class org.apache.commons.logging.LogFactory
25:   [java] [DEBUG] Class org.apache.commons.logging.LogFactory
loaded from ant loader
26:   [java] [DEBUG] Class java.security.PrivilegedAction loaded from
parent loader
27:   [java] [DEBUG] Finding class
org.apache.commons.logging.LogConfigurationException

On my line 25: maven/ant is able to load the
org.apache.commons.logging.LogFactory class.

24:   [java] [DEBUG] Finding class org.apache.commons.logging.LogFactory
25:   [java] [ERROR] java.lang.NoClassDefFoundError
26:   [ant] [DEBUG]  +User task: propertyfile    
org.apache.tools.ant.taskdefs.optional.PropertyFile
27:   [ant] [DEBUG]  +User task: vsscheckin    
org.apache.tools.ant.taskdefs.optional.vss.MSVSSCHECKIN

while on your line 25 (http://rafb.net/paste/results/I89rnj81.html)
there's a java.lang.NoClassDefFoundError...so i believe you have a
rogus commons-logging somewhere that is causing this problem. As you
mentioed you don't have a problem running the
"org.apache.geronimo.ews.ws4j2ee.utils.packager.Packager" task from
the command line which further reinforces this notion of mine.....

-- dims

-- 
Davanum Srinivas - http://webservices.apache.org/~dims/

Mime
View raw message