geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mouli <uc_mo...@yahoo.com>
Subject Re: error
Date Fri, 15 Oct 2004 01:38:39 GMT
This worked.

thanks,
mouli
--- Gianny Damour <gianny.damour@optusnet.com.au>
wrote:

> On 14/10/2004 3:20 AM, mouli wrote:
> 
> >    [mkdir] Created dir:
>
>C:\asf\geronimo\modules\assembly\target\geronimo-1.0-SN
> >APSHOT\bin
> >    [mkdir] Created dir:
>
>C:\asf\geronimo\modules\assembly\target\geronimo-1.0-SN
> >APSHOT\config-store
> >    [echo] Building server.jar
> >    [java] Server URI: org/apache/geronimo/System
> >    [echo] Building server configuration
> >    [java]
> >org.apache.geronimo.deployment.DeploymentException:
> >Unable to load pa
> >rents
> >    [java]      at
>
>org.apache.geronimo.deployment.DeploymentContext.<init>(Deplo
> >ymentContext.java:114)
> >  
> >
> <...>
> When configurations, modules or plans, are
> successfully deployed, the 
> deployer displays their URIs. So, for sure
> org/apache/geronimo/System 
> has been installed.
> 
> >    [java] Caused by:
>
>org.apache.geronimo.kernel.config.NoSuchConfigException:
> >N
> >o configuration with id: org/apache/geronimo/System
> >    [java]      at
>
>org.apache.geronimo.kernel.config.ConfigurationManagerImpl.lo
> >ad(ConfigurationManagerImpl.java:129)
> >    [java]      at
>
>org.apache.geronimo.kernel.config.ConfigurationManagerImpl.lo
> >adRecursive(ConfigurationManagerImpl.java:175)
> >    [java]      at
>
>org.apache.geronimo.deployment.DeploymentContext.<init>(Deplo
> >ymentContext.java:112)
> >  
> >
> <...>
> I am so happy! I am not the only one to have faced
> this problem. If you 
> look into your 
>
modules/assembly/target/geronimo-1.0-SNAPSHOT/config-store
> directory you 
> will see the standard index.properties file along
> with another file 
> named index<ID>.tmp. This latter should have
> replaced index.properties, 
> yet it seems that index.properties has not been
> successfully deleted.
> 
> So, perhaps that LocalConfigStore should check that
> index.properties has 
> been successfully deleted and that index<ID>.tmp has
> been successfully 
> renamed.
> 
> >what needs to be done to fix this?
> >  
> >
> On my side, I have simply rebuilt the assembly
> module and it was OK. I 
> have not been able to re-create the problem.
> 
> Are we the only ones to have encountered this
> problem?
> 
> Thanks,
> Gianny
> 


=====
---------------***************---------------
mouli


	
		
__________________________________
Do you Yahoo!?
Yahoo! Mail - You care about security. So do we.
http://promotions.yahoo.com/new_mail

Mime
View raw message