geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Boynes <jboy...@gluecode.com>
Subject Re: Oops, we did it again - build broken?
Date Thu, 09 Sep 2004 15:29:56 GMT
It failed for me in a different way - it was depending on the M2 build 
rather than the current one. I changed the version back to SNAPSHOT and 
it now builds for me.

--
Jeremy

Jacek Laskowski wrote:

> Hi,
> 
> Is it only me who's facing build problems in maven-plugin?
> 
> java:prepare-filesystem:
>     [mkdir] Created dir: 
> C:\projects\incubator-geronimo\modules\maven-plugin\target\classes
> 
> java:compile:
>     [echo] Compiling to 
> c:\projects\incubator-geronimo\modules\maven-plugin/target/classes
>     [javac] Compiling 11 source files to 
> C:\projects\incubator-geronimo\modules\maven-plugin\target\classes
> C:\projects\incubator-geronimo\modules\maven-plugin\src\java\org\apache\geronimo\deployment\mavenplugin\StopRemoteServer

> 
> .java:40: cannot resolve symbol
> symbol  : method shutdown ()
> location: interface org.apache.geronimo.kernel.KernelMBean
>             kernel.shutdown();
>                   ^
> C:\projects\incubator-geronimo\modules\maven-plugin\src\java\org\apache\geronimo\deployment\mavenplugin\WaitForStarted.j

> 
> ava:82: cannot resolve symbol
> symbol  : method getConfigurationState (java.net.URI)
> location: interface org.apache.geronimo.kernel.KernelMBean
>             int state = kernel.getConfigurationState(id);
>                               ^
> 2 errors
> 
> I can't sort it out now. Perhaps, by the time I'll be looking into it 
> (tonight of GMT+1) it will have already done.
> 
> Best,
> Jacek

Mime
View raw message