geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From toby cabot <t...@caboteria.org>
Subject web app calling ejb: "class not found" at deployment
Date Thu, 05 Aug 2004 15:31:23 GMT
Hi Folks,

I'm trying to deploy a web application that calls an EJB.  I can
deploy the EJB and call if from a command-line Java client, so I think
that part works, thanks to this list for help with JNDI.

I did the usual stuff in the servlet, but when I add

    <ejb-ref>
        <ejb-ref-name>g6o/SSEJB</ejb-ref-name>
        <ejb-ref-type>Session</ejb-ref-type>
        <home>g6o.ejbclient.StatelessSessionHome</home>
        <remote>g6o.ejbclient.StatelessSession</remote>
    </ejb-ref>

to web.xml I get a stack trace when I run the deploy tool.

org.apache.geronimo.deployment.DeploymentException: Remote interface class not found: g6o.ejbclient.StatelessSession
        at org.apache.geronimo.jetty.deployment.JettyModuleBuilder.assureInterface(JettyModuleBuilder.java:593)
        at org.apache.geronimo.jetty.deployment.JettyModuleBuilder.assureEJBObjectInterface(JettyModuleBuilder.java:573)
        at org.apache.geronimo.jetty.deployment.JettyModuleBuilder.addEJBRefs(JettyModuleBuilder.java:491)

	etc...

I've got the EJB interfaces in a jar in the war file's WEB-INF/lib
directory, but I also tried putting the jar with the EJB interfaces in
geronimo's lib directory with the same result.

Any help gratefully appreciated.

Toby


Mime
View raw message