geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From toby cabot <t...@caboteria.org>
Subject Re: ResourceAdapter.start() not getting called?
Date Sat, 10 Jul 2004 18:50:54 GMT
David,

Thank you for the tips (on a weekend no less)!  I pulled the source
from CVS this morning so I should be reasonably up to date.

> Can you look in the geronimo log (target/var/log/geronimo.log) and look  
> for messages about the ResourceAdapterWrapper gbean?  There is probably  
> some information about a missing dependency or similar problem.  If  
> it's not obvious what the problem is please post the log.

Here's the part of the log that seems relevant:

14:17:19,320 DEBUG [GBeanMBean] geronimo.security:type=LoginConfiguration State changed from
stopped to starting
14:17:19,330 DEBUG [GBeanMBean] geronimo.security:type=LoginConfiguration State changed from
starting to running
14:17:19,330 DEBUG [GBeanMBean] geronimo.config:name="testRA" State changed from stopped to
starting
14:17:19,335 DEBUG [Configuration] ClassPath for testRA resolved to [file:/home/tobyc/try/incubator-geronimo/target/config-store/8/connector/skeleton-ra.jar]
14:17:19,669 INFO  [Configuration] Started configuration testRA
14:17:19,669 DEBUG [GBeanMBean] geronimo.config:name="testRA" State changed from starting
to running
14:17:19,670 DEBUG [GBeanMBean] geronimo.server:J2EEApplication=null,J2EEServer=geronimo,ResourceAdapterModule=testRA,j2eeType=ResourceAdapter,name=testRA
State changed from stopped to starting
14:17:19,673 DEBUG [GBeanMBean] Waiting to start: objectName="geronimo.server:J2EEApplication=null,J2EEServer=geronimo,ResourceAdapterModule=testRA,j2eeType=ResourceAdapter,name=testRA"
reason="No targets are running for bootstrapContext reference"
14:17:19,673 DEBUG [GBeanMBean] geronimo.server:J2EEApplication=null,J2EEServer=geronimo,j2eeType=ResourceAdapterModule,name=testRA
State changed from stopped to starting
14:17:19,687 DEBUG [GBeanMBean] geronimo.server:J2EEApplication=null,J2EEServer=geronimo,j2eeType=ResourceAdapterModule,name=testRA
State changed from starting to running
14:17:19,687 DEBUG [GBeanMBean] geronimo.server:role=JMXService,name=localhost State changed
from stopped to starting


Does this imply that my geronimo-ra.xml

<bootstrapcontext-name>geronimo.connector:role=BootstrapContext</bootstrapcontext-name>

element is wrong?  It wouldn't surprise me since I'm not clear on what
that element's supposed to do anyway.

Thanks,
Toby

Mime
View raw message