geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Uusisalo" <jukka.uusis...@dnainternet.net>
Subject Re: Help needed : running sample struts webapp
Date Wed, 05 May 2004 20:43:18 GMT

----- Original Message ----- 
From: "Eric Le Goff" <eric.le-goff@gicm.fr>
To: <geronimo-dev@incubator.apache.org>
Sent: Wednesday, May 05, 2004 1:11 PM
Subject: Help needed : running sample struts webapp


> My first attempt to run the 1.0M1 server failed :
> from GERONIMO_HOME I did
>
> 1) deploy the struts-example.war with
> java -jar ./bin/deploy.jar --install --module struts-example.war
> (including WEB-INF/geronimo-jetty.xml)
>
> 2) start my geronimo server with
>
> java -jar ./bin/server.jar net/mydomain/Example
>
> and got :
>
> [...]
> 12:00:01,928 WARN  [XmlParser]
> WARNING@http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd line:101 col:46
> : org.xml.sax.SAXParseException: src-include.0: Failed to read included

Propably typo in web.xml at web-app tag. Below is snippet how it should be,
i think.

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
                 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                 xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee

http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
                 version="2.4">

I had web.xml template where that was

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
                 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                 xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
                                                  web-app_2_4.xsd"
                 version="2.4">

And i have used that with tomcat 5.0.16 without any problem.

- Jukka -


Mime
View raw message