Hi,
 
I did a build from the cvs check out, the build was successful. I am getting a ClassNot Found exception(net/sf/cglib/reflect/FastClass) when i am starting the server.
 
I cleaned the maven repository twice, did a new cvs checkout and tried, but in vain.
 
maven run, maven run:server (from project home directory)
java -jar bin/server.jar org/apache/geronimo/Server and java -jar bin/server.jar org/apache/geronimo/DebugConsole (from targets directory)
 
gives this exception
Exception in thread "main" java.lang.NoClassDefFoundError: net/sf/cglib/reflect/FastClass
        at org.apache.geronimo.gbean.jmx.GBeanMBean.<clinit>(GBeanMBean.java:67)
        at org.apache.geronimo.system.main.Daemon.main(Daemon.java:81)
 
I can see this class in target\lib\cglib-full-2.0.jar, I guess the classloader takes care of loading this and i need not set any classpath explicitly.
 
And a weird thing happens when i run "maven debug:server"
C:\cvs\apache\geronimo\incubator-geronimo>maven debug:server
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0-rc2
 
build:start:
 
debug:server:
    [echo] Running in target/bin
_
and it just stops there infinitely.....
 
Am I doing anything wrong, some pointer would be helpful.
 
Windows XP, java version "1.4.2_03" , maven 1.0-rc2
 
regards,
Arun