geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <da...@coredevelopers.net>
Subject Re: velocity-based debug console
Date Mon, 16 Feb 2004 22:03:39 GMT
<howl of protest>I would rather you used one less level so we don't 
have to rewrite all of top level maven.xml to include it in the normal 
build. </howl of protest>

david jencks

On Monday, February 16, 2004, at 01:53 PM, Geir Magnusson Jr wrote:

> If no one objects then, I'm going to go with :
>
> /geronimo/applications/console/jmx-debug
>
> and get things in there and working so others can play.  Right now, 
> it's just read-only, but still vaguely useful.
>
> I'll wait a bit for any agreement or howls of protest.
>
> geir
>
>
> On Feb 15, 2004, at 11:09 PM, n. alex rupp wrote:
>
>> We've got the following:
>>
>> CLI console
>> Swing console
>> Web console
>> JMX debugging console
>>
>> So perhaps we should have:
>>
>> /geronimo/applications/console/cli
>> /geronimo/applications/console/swing
>> /geronimo/applications/console/web
>> /geronimo/applications/console/jmx-debug
>>
>> Can they all be classified as applications?  I know the two web apps 
>> can--if the
>> other two can as well I'm game for an "applications" branch : )  We 
>> should also
>> consider how to name the  .WAR files for the two web applications in 
>> this list.
>>
>> I guess "jmx-debug.war" and "server-management.war" might work out.  
>> So you'd
>> have "...8080/jmx-debug/" and "...8080/server-management/"
>>
>> I'm happy with however you guys decide to name these, as long as they 
>> make some
>> logical sense to the users and aren't any more verbose than is 
>> necessary.
>>
>> --
>> N. Alex Rupp
>>
>>
>>
>> ----- Original Message -----
>> From: "Dain Sundstrom" <dain@coredevelopers.net>
>> To: <geronimo-dev@incubator.apache.org>
>> Sent: Sunday, February 15, 2004 1:24 PM
>> Subject: Re: velocity-based debug console
>>
>>
>>> I think we need a new naming convention.  The console-<type> was
>>> designed with the idea that we would have a single console of each 
>>> type
>>> (e.g., console-web, console-gui, console-cli).  Now the new stuff is
>>> not a management console, just a debug tool, so console-<type> 
>>> doesn't
>>> really fit.  Instead debug-web, would fit better, unfortunately that
>>> name implies it is a debug tool for web applications, which it
>>> definitely is not.  This is why I think we need a new naming
>>> convention.
>>>
>>> Also Jeremy suggested the other day that we put these modules into a
>>> new applications "modules-tree" (e.g. geronimo/modules/console-web
>>> becomes geronimo/applications/console-web/).  Another idea is to use 
>>> a
>>> two level deep tree (e.g. geronimo/modules/console-debug becomes
>>> geronimo/applications/console/web/).
>>>
>>> What ever we decide, I think we need to readdress the naming 
>>> convention
>>> for applications.
>>>
>>> -dain
>>
>>
> -- 
> Geir Magnusson Jr                                   203-247-1713(m)
> geir@4quarters.com
>


Mime
View raw message