geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryce Alcock <Br...@licosystems.com>
Subject Re: Build Failure...
Date Thu, 26 Feb 2004 05:46:48 GMT

Ok This is still failing, see below:

Kristian Köhler wrote:

> Hi
>
> Bryce Alcock wrote:
>
>> Greetings,
>>
>> Trying to build this product, and getting the following types of errors:
>>
>> first I update cvs,  (always nice to see new code:)
>> CVSROOT: anonymous@cvs.sourceforge.net:/cvsroot/middlegen (password 
>
>                                                   ^^^^^^^^^^
> are you sure you are getting geronimo?
>
>> authentication)
>> TCL is available, shell is enabled : help (select and press enter)
>> cvs -z9 update -P -d (in directory C:\apache\incubator-geronimo\)
>
>
> Please see also at
> http://wiki.apache.org/geronimo/BuildingAndRunning
>
> There you will find a short description how to build geronimo. Just 
> typ maven in the incubator-geronimo directory.
>
> ---- 8< ----
>
> cvs -qz3 -d:pserver:anoncvs@cvs.apache.org:/home/cvspublic co 
> incubator-geronimo
> cd incubator-geronimo
> cvs -qz3 update -dP
> maven
>
> ---- 8< ----
>
> BTW ant isn't requiered to build geronimo.
>
> Kristian
>
>>
Ok,
Actually I did have geronimo.  the wincvs client lists the "default" 
login for new projects
without a CVS folder.  However, I had check this out a few days earlier, 
and since the
CVS folder already existed wincvs used the CVSROOT associated with that 
directory.
However, to play fair and quench your concerns I changed my default CVSROOT
to the geronimo project.  seen Below:

-----------------------------------------------------------------------------------------
Python 2.1.1 (#20, Jul 20 2001, 01:19:29) [MSC 32 bit (Intel)] on win32
CVSROOT: anoncvs@cvs.apache.org:/home/cvspublic (password authentication)
TCL is available, shell is enabled : help (select and press enter)
cvs -z9 update -P -A -d -C (in directory C:\apache\incubator-geronimo\)
-----------------------------------------------------------------------------------------

Then I tried the following commands:
1.  maven
      result BUILD FAILED
2.  maven build
      result BUILD FAILED
3.  maven clean
      result BUILD FAILED
4.  maven build   (a second time)
      result BUILD FAILED
5.  maven clobber
      result BUILD FAILED
6.  maven build  (a third time)
      result BUILD FAILED
7.  maven -g
      Listed more options than you can shake a stick at.

------------------------------------------------------------------------------------------------

The maven, and maven build commands always give the same failure:


C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:31: package org.apache.xmlbeans does not exist
import org.apache.xmlbeans.SchemaTypeSystem;
                           ^
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:32: package org.apache.xmlbeans does not exist
import org.apache.xmlbeans.SchemaTypeLoader;
                           ^
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:33: package org.apache.xmlbeans does not exist
import org.apache.xmlbeans.XmlBeans;
                           ^
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:34: package org.apache.xmlbeans does not exist
import org.apache.xmlbeans.XmlOptions;
                           ^
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:35: package org.apache.xmlbeans does not exist
import org.apache.xmlbeans.XmlObject;
.
.
.
.
.
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:670: cannot resolve symbol
symbol  : class SchemaCompilerExtension
location: class org.apache.geronimo.tools.xmlbeans.SchemaCompiler
                    sce = (SchemaCompilerExtension) 
extension.getClassName().newInstance();
                           ^
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:690: package Extension does not exist
                    Extension.Param p = (Extension.Param) parmsi.next();
                             ^
C:\apache\incubator-geronimo\modules\maven-xmlbeans-plugin\src\java\org\apache\geronimo\tools\xmlbea
ns\SchemaCompiler.java:690: package Extension does not exist
                    Extension.Param p = (Extension.Param) parmsi.next();
                                                  ^
100 errors

BUILD FAILED
File...... file:/C:/apache/incubator-geronimo/
Element... maven:reactor
Line...... 179
Column.... 27
Unable to obtain goal [default] -- file:/E:/Documents and 
Settings/Bryce/.maven/plugins/maven-java-p
lugin-1.3/:34:48: <ant:javac> Compile failed; see the compiler error 
output for details.
Total time: 48 seconds
Finished at: Wed Feb 25 21:39:06 PST 2004


IS THERE SOME DEPENDENCY THAT I AM MISSING?
I WAS REALLY UNDER THE IMPRESSION THAT maven WAS
RESPONSIBLE FOR DOWNLOADING AND INSTALLING
ANY REQUIRED JARs.

 
*********************************************
*********************************************

The 'maven clean' command fails with the following:



BUILD FAILED
File...... file:/C:/apache/incubator-geronimo/
Element... maven:reactor
Line...... 179
Column.... 27
The build cannot continue because of the following unsatisfied dependency:

geronimo-xmlbeans-plugin-DEV.jar (no download url specified)

Total time: 1 minutes 31 seconds
Finished at: Wed Feb 25 21:44:19 PST 2004


Mime
View raw message