geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Mueller <pmue...@yahoo.com>
Subject Re: 'maven rebuild' fails, but 'maven build' works?
Date Wed, 25 Feb 2004 16:42:12 GMT
Jacek Laskowski wrote:

> Hey,
> 
> Doing 'maven rebuild' the build failed, but 'maven build' finished 
> properly. I've seen it several times - although 'maven rebuild' failed 
> (with all the libs downloaded) 'maven build' worked well.

I also had a problem with, I think just 'maven' this morning; it's been 
a couple of days since I updated.  I was able to get a clean running 
build by doing a 'clean' and then 'build'.  My console log has rolled, 
so I don't know exactly what else I tried, but I think I tried a 
rebuild.  At one point I got an error like this:

BUILD FAILED
File...... file:/incubator-geronimo/
Element... maven:reactor
Line...... 179
Column.... 27
Unable to obtain goal [default] -- 
file://.maven/plugins/maven-jar-plugin-1.3/:206:7:
  <ant:copy> Failed to copy 
incubator-geronimo\modules\kernel\target\geronimo-kernel-DEV.jar to 
.maven\repository\geronimo\jars\geronimo-kernel-DEV.jar due to 
.maven\repository\geronimo\jars\geronimo-kernel-DEV.jar (Access is denied)

[I have wacked the directories on the file names to protect my innocence 
<grin/>]

Pretty weird (Access is denied), but actually, I'm used to seeing wacky 
stuff like that from Ant.  We've never figured out what's causing it, 
and have at times resorted to create 'sleep' tasks in Ant to let it 
'settle' between interesting tasks.  ick.

But again, a 'maven clean' followed by a 'maven build' got me up and 
going again.

-- 
Patrick Mueller
pmuellr@yahoo.com

Mime
View raw message