geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srinath Perera" <hemap...@opensource.lk>
Subject Re: [EWS] Need to fix GenerateTest (for testing ws4j2ee)
Date Fri, 06 Feb 2004 12:09:46 GMT
Hi All;
I fix the GenarateTest .. Actually each test case we used for the
test the ws4j2ee should have three parts
1) genarate the Client side with wsdl
2) genarete the serve side with wsdl
3) Genarate the all when wsdl not present using the ejb jar.
(It was  my mistake to put the code at test to genarate the client side
code only)

With the recent axis code the wsdl generatin code give a null pointer
exception. When I try it in WSDL2Java gives the same result .. I am not
sure is it something to do with axis or ws4j2ee. I will check.

when that is done the ws4j2ee support the all 1,2,3 senario's. With the
1) it will genarate a build file that would automate the jar creation.

As Guillaume pointed out we(myself aand Chatura) will replace/merge the
code that do the manual parsing of webservice.xml with the JAXB code over
the weekend.

Thanks

Srinath




> Ias, Srinath,
>
> Can you guys please fix the GenerateTest test that i added for ws4j2ee?
> Am not sure where the problem is happening. You need to edit project.xml
> and comment out the excludes section in unitTest block and then run
> "maven" to recreate the problem.
>
> thanks,
> dims
>
> =====
> Davanum Srinivas - http://webservices.apache.org/~dims/


------------------------------------
Lanka Sofware Foundation
------------------------------------



Mime
View raw message