geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <jacek.laskow...@hp.com>
Subject Renaming methods in o.a.g.kernel.deployment.AbstractDeploymentPlanner
Date Sun, 14 Dec 2003 15:38:11 GMT
Hi,

I wonder why are the methods of 
o.a.g.kernel.deployment.AbstractDeploymentPlanner:

     protected abstract boolean addURL(DeployURL deployURL, Set goals, 
Set plans) throws DeploymentException;

     protected abstract boolean redeployURL(RedeployURL redeployURL, Set 
goals) throws DeploymentException;

     protected abstract boolean removeURL(UndeployURL undeployURL, Set 
goals, Set plans) throws DeploymentException;

named this way?

Wouldn't it be better off with the names changed to:

     protected abstract boolean deployURL(DeployURL deployURL, Set 
goals, Set plans) throws DeploymentException;

     protected abstract boolean redeployURL(RedeployURL redeployURL, Set 
goals) throws DeploymentException;

     protected abstract boolean undeployURL(UndeployURL undeployURL, Set 
goals, Set plans) throws DeploymentException;

The names would then be more consistent with the names of the first 
input parameter (actually redeployURL is so). Also, they would be more 
meaningful (at least to me :-))

The first time I saw addURL I thought it'd add a URL to the list of 
deployments to deploy, but quickly realized that it did even more, it 
added the URL to the list of deployments by deploying it.

Jacek




Mime
View raw message