geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Carlos Vergara <jcvers...@tss.com.pe>
Subject RE: Help building and running Geronimo
Date Sat, 15 Nov 2003 02:18:37 GMT
Thanks Alan;
There was an error in the CVSGrab, it did not bring back some files.
Now all is ok.
Thanks a lot for your help

Regards,
-- JC

-----Mensaje original-----
De: Alan D. Cabrera [mailto:adc@toolazydogs.com]
Enviado el: Friday, November 14, 2003 8:59 PM
Para: geronimo-dev@incubator.apache.org
Asunto: RE: Help building and running Geronimo


There should be a bunch of files in that directory, including the
maven.xml and project.xml file.  Maybe something went wrong w/ the CVS
checkout?

> -----Original Message-----
> From: Juan Carlos Vergara [mailto:jcversant@tss.com.pe]
> Sent: Friday, November 14, 2003 8:58 PM
> To: geronimo-dev@incubator.apache.org
> Subject: RV: Help building and running Geronimo
> 
> Thanks for your help Alan!
> 
> But in the Geronimo directory there isn't any Maven file.
> 
> I had the following error:
> 
>  __  __
> |  \/  |__ _Apache__ ___
> | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> |_|  |_\__,_|\_/\___|_||_|  v. 1.0-rc1-SNAPSHOT
> 
> BUILD FAILED
> No goal specified and no project.xml found.
> Total time: 1 seconds
> Finished at: Fri Nov 14 20:51:32 COT 2003
> 
> Which is exactly the command to execute?
> 
> Regards,
> 
> -- JC
> 
> -----Mensaje original-----
> De: Alan D. Cabrera [mailto:adc@toolazydogs.com]
> Enviado el: Friday, November 14, 2003 8:47 PM
> Para: geronimo-dev@incubator.apache.org
> Asunto: RE: Help building and running Geronimo
> 
> 
> Run maven in the Geronimo directory.
> 
> Regards,
> Alan
> 
> > -----Original Message-----
> > From: Juan Carlos Vergara [mailto:jcversant@tss.com.pe]
> > Sent: Friday, November 14, 2003 8:47 PM
> > To: geronimo-dev@incubator.apache.org
> > Subject: Help building and running Geronimo
> > Importance: High
> >
> > Hello Geronimo-List;
> >
> > I was downloaded the Geronimo's Maven repository with the grabCVS
> utility
> > because I am under firewall.
> >
> > As a result I have the following directory structure:
> >
> > Geronimo
> > 	|
> > 	|etc
> > 	|module
> > 	|specs
> > 	|xdocs
> >
> > Attemp 1:
> >
> > When I run Maven inside the etc directory I had the following
message:
> >
> > java:compile:
> >     [echo] Compiling to F:\Workspaces\Geronimo\etc\target\classes
> >     [echo] No java source files to compile.
> >
> >
>
========================================================================
> ==
> > ==
> > =================
> > This is all the Maven's output:
> >
> > default:
> > java:prepare-filesystem:
> >     [mkdir] Created dir: F:\Workspaces\Geronimo\etc\target\classes
> >
> > java:compile:
> >     [echo] Compiling to F:\Workspaces\Geronimo\etc\target\classes
> >     [echo] No java source files to compile.
> >
> > java:jar-resources:
> >
> > test:prepare-filesystem:
> >     [mkdir] Created dir:
> F:\Workspaces\Geronimo\etc\target\test-classes
> >     [mkdir] Created dir:
> F:\Workspaces\Geronimo\etc\target\test-reports
> >
> > test:test-resources:
> >
> > test:compile:
> >     [echo] No test source files to compile.
> >
> > test:test:
> >     [echo] No tests to run.
> >     [touch] Creating
> F:\Workspaces\Geronimo\etc\target\test-reports\tstamp
> >
> > jar:jar:
> >     [jar] Building jar:
> F:\Workspaces\Geronimo\etc\target\geronimo-DEV.jar
> >
> > jar:install:
> >     [echo]
> >     id = 'geronimo'
> >     groupId = 'geronimo'
> >     artifactDirectory = 'geronimo'
> >
> >     [mkdir] Created dir: C:\Documents and
> > Settings\jcvergara\.maven\repository\geronimo\jars
> >     [copy] Copying 1 file to C:\Documents and
> > Settings\jcvergara\.maven\repository\geronimo\jars
> > BUILD SUCCESSFUL
> > Total time: 13 minutes 41 seconds
> > Finished at: Fri Nov 14 19:39:44 COT 2003
> >
>
========================================================================
> ==
> > ==
> > =================
> >
> > Attempt 2: I tried to build a single Geronimo's module with the
> following
> > command (Geronimo's common):
> >
> > - F:\Workspaces\Geronimo\modules\common>maven
> >
> > I had the following error:
> >
> >
>
========================================================================
> ==
> > ==
> > =================
> > The build cannot continue because of the following unsatisfied
> dependency:
> > geronimo-kernel-DEV.jar (no download url specified)
> >
>
========================================================================
> ==
> > ==
> > =================
> >
> > Please tell me how we should run Maven to build and run Geronimo.
> >
> > Thanks in advance
> >
> > -- JC
> >
> >
> >

Mime
View raw message