geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <d...@coredevelopers.net>
Subject Re: [jsr77][core] AbstractContainer start dependancies
Date Tue, 16 Sep 2003 16:47:36 GMT
On Monday, September 15, 2003, at 05:17 PM, Jan Bartel wrote:

>> Anyway, I think we should change the signature of DependencyService 
>> from
>> addStartDependency(ObjectName startChild, ObjectName startParent)
>> to
>> addStartDependency(ObjectName startParent, ObjectName startChild)
>> It is just more natural to think parent then child.
>
> That'll really confuse things :-)  I actually think it is better the 
> way it is,  so you are stating the thing that is dependent before the 
> thing on which it is dependent (in English: THIS depends on THAT).

I was going to disagree on this, because I think the idiomatic usage of 
Parent-Child vastly out weighs the This depends on That usage, but once 
I got into the code I think your way is better.  There are a lot of 
methods in the dependency service that use the This depends on That 
style and on a whole I think it is clear that way.

My feelings on this are not strong, so if someone want to change the 
group opinion, I for one am open.

I committed a change to AbstractContainer that fixes this for now, but 
this class is going away, so the change is a bit moot.

-dain


Mime
View raw message