geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Mulder <>
Subject Re: [JSR-88] Which Java Package?
Date Thu, 14 Aug 2003 03:55:57 GMT
	I'm fine with .server and .tool, but I don't think .common is 
necessarily right for the other stuff.  I guess by "the other stuff", I'm 
thinking of any kind of "back end logic" responsible for doing stuff on 
the server side, that won't be exposed to the client.

	Just saying that though makes me think that perhaps ".server" 
doesn't mean what we want it to mean.  Perhaps they should be

.enterprise.deploy.provider  // the JSR-88 provider code
.enterprise.deploy.tool      // the JSR-88 tool code
.enterprise.deploy.server    // the back-end Geronimo logic that
                             // is not specific to JSR-88

	My only concern is that if we have any subpackages, a 7-part 
package name is kind of gross.


On Wed, 13 Aug 2003, Jonathan Duty wrote:
> How about
> geronimo.enterprise.deploy.common
> geronimo.enterprise.deploy.server
> geronimo.enterprise.deploy.tool
> Let me know if I'm totally not understanding things (which could very
> well be). ~Jonathan

View raw message