geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Murmann (JIRA)" <>
Subject [jira] [Updated] (GEODE-1409) Pulse view does not display cluster and members when in France
Date Thu, 08 Mar 2018 00:07:00 GMT


Alexander Murmann updated GEODE-1409:
    Labels: starter  (was: newbie)

> Pulse view does not display cluster and members when in France
> --------------------------------------------------------------
>                 Key: GEODE-1409
>                 URL:
>             Project: Geode
>          Issue Type: Bug
>          Components: pulse
>            Reporter: Eitan Suez
>            Priority: Major
>              Labels: starter
> If you setup your cluster with and user.language=fr (france) when starting
your locator and servers, then when you start pulse, log in, you will not see your cluster
nor any members.
> the reason is that the http post that the client does to the pulse controller (/pulseUpdate)
does not return members.
> we see this in the pulse logs:
> [WARNING 2016/05/17 10:15:56.489 CEST qtp22145019-209 tid=0xd1] (msgTID=209 msgSN=29665)
> []
> serviceException [for service ClusterMembersRGraph] = For input string: "30,58"
> it looks like the service exception might have some kind of number parsing exception
when encountering numeric values formatted according to the french locale.  so it encounters
30,58 and doesn't properly interpret it as 30.58.. that has the side effect of fetching cluster
information not returning anything.

This message was sent by Atlassian JIRA

View raw message