geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Rowe (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (GEODE-4010) Locator should not require non-gossip request version to be written for new protocol
Date Thu, 07 Dec 2017 21:39:00 GMT

     [ https://issues.apache.org/jira/browse/GEODE-4010?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brian Rowe resolved GEODE-4010.
-------------------------------
    Resolution: Duplicate

The change for GEODE-4059 will include a fix for this issue.

> Locator should not require non-gossip request version to be written for new protocol
> ------------------------------------------------------------------------------------
>
>                 Key: GEODE-4010
>                 URL: https://issues.apache.org/jira/browse/GEODE-4010
>             Project: Geode
>          Issue Type: Bug
>          Components: client/server
>            Reporter: Michael Dodge
>             Fix For: 1.4.0
>
>
> When connecting to a server using the new protocol, two bytes must be written, the communication
mode and the major version. The locator, however, currently insists on four bytes of non-gossip
request version (all zeros) being written _before_ the other two bytes. This insistence should
be removed to ensure consistent behavior between locator and server for the new protocol.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message