geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <>
Subject [jira] [Commented] (GEODE-4008) InvalidClassException when deserializing FunctionAdapter from pre Geode clients
Date Mon, 11 Dec 2017 20:49:00 GMT


ASF subversion and git services commented on GEODE-4008:

Commit 36eeafefc3597cfcb1b2d2673734effd806e686d in geode's branch refs/heads/develop from
[;h=36eeafe ]

Revert "GEODE-4008: Added serialVersionUID to FunctionAdapter (#1119)"

This reverts commit 6578ecce6705b33a47264db72cab72aa6a991d51.

> InvalidClassException when deserializing FunctionAdapter from pre Geode clients
> -------------------------------------------------------------------------------
>                 Key: GEODE-4008
>                 URL:
>             Project: Geode
>          Issue Type: Bug
>          Components: functions
>            Reporter: Jason Huynh
>            Assignee: Jason Huynh
>             Fix For: 1.4.0
> There was a change to deprecate FunctionAdapter in Geode, and this removed the method
signatures of the class.  This causes Java to assign a new serialVersionUID to the class.
 However we have clients pre Geode that when they attempt to execute a function by serializing
the function across (not using a function id), the FunctionAdapter class is unable to deserialize
> The proposed fix is to assign a serialVersionUID to the class that matches that of the
pre Geode FunctionAdapter.  This will cause any Geode 1.0-1.3 clients to run into this same
error.  However FunctionAdapter has been deprecated and it would be easy enough to just change
the classes to implement Function.

This message was sent by Atlassian JIRA

View raw message