geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Martell (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GEODE-3588) Restarting a Locator Loses Cluster Configuration
Date Mon, 11 Sep 2017 18:05:02 GMT

     [ https://issues.apache.org/jira/browse/GEODE-3588?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Martell updated GEODE-3588:
-----------------------------------
    Attachment: RunLocalhostGemfire.ps1

> Restarting a Locator Loses Cluster Configuration
> ------------------------------------------------
>
>                 Key: GEODE-3588
>                 URL: https://issues.apache.org/jira/browse/GEODE-3588
>             Project: Geode
>          Issue Type: Bug
>          Components: configuration, gfsh, membership
>            Reporter: Michael Martell
>         Attachments: RunLocalhostGemfire.ps1
>
>
> Restarting the locator and listing members works properly. Repeating the process a second
time shows no cluster members.
> To repro:
> 1) start a locator
> 2) start a server
> 3) list members (shows locator and server)
> 4) stop the locator
> 5) restart the locator (same as step 1)
> 6) list members (shows locator and server)
> 7) stop the locator a second time
> 8) restart the locator a second time (same as step 1)
> 9) list members shows only the locator
> Notes:
> - This was done on a Windows machine using latest geode/develop (as of 9/11/2017)
> - Was tried with and without using protobuf=true flag, and fails in both cases)



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message